my dog learned polymorphism*
The moose likes Beginning Java and the fly likes Bug in JDK 1.4 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "Bug in JDK 1.4" Watch "Bug in JDK 1.4" New topic
Author

Bug in JDK 1.4

ryan headley
Ranch Hand

Joined: Jun 28, 2000
Posts: 156
Is there a change or bug in JRE 1.4 where if you have a TextArea in a ScrollPane that any text in the TextArea can't be highlighted and copied with Control-C?
The reason I ask is I have an app that I wrote originally to run in JRE 1.3. I transferred the application to another machine where I compiled it cleanly with JDK 1.4 and the new machine has both JRE 1.3 AND 1.4 on it. Copying with Contorl-C worked until I installed JRE 1.4. Now I cannot highlight the text.
Anyone aware of this?


Ryan Headley<br /><a href="http://www.sudovi.com" target="_blank" rel="nofollow">http://www.sudovi.com</a>
Cindy Glass
"The Hood"
Sheriff

Joined: Sep 29, 2000
Posts: 8521
Don't know, but you can look here


"JavaRanch, where the deer and the Certified play" - David O'Meara
Michael Bruesch
Ranch Hand

Joined: Sep 23, 2001
Posts: 158
Is there a JDK 1.4 now? Am I behind the times? Is it still in beta phase? I feel like I'm out of the "loop", no programming pun intended...


Michael J Bruesch<br /><i>I code, therefore I am.</i>
Michael Bruesch
Ranch Hand

Joined: Sep 23, 2001
Posts: 158
Alright, I saw it on java.sun.com . Cindy or someone in the know, would y'all recommend waiting or go ahead and download the 1.4 Beta version? And will I have to download the 1.4 docs too? I'm back to 56k temporarily, so that would be a big headache, but, gotta keep up to speed!
Thanks in advance.
ryan headley
Ranch Hand

Joined: Jun 28, 2000
Posts: 156
Michael,
The only reason I installed it was because they gave me a brand new laptop at work. I figured I might as well, and that way I could keep up.
I haven't heard much from anyone else using it yet.
Michael Bruesch
Ranch Hand

Joined: Sep 23, 2001
Posts: 158
So you advise to wait?
Cindy Glass
"The Hood"
Sheriff

Joined: Sep 29, 2000
Posts: 8521
Well, I like to play . So I immediately downloaded the beta version. It is BIG (almost 69M), but I have lots of room so. . . .
If you are just learning Java, stick with 1.2 or 1.3. You have ENOUGH to worry about already.
If you are studying for the exam, none of the newer stuff is on it yet - not even Swing.
If you are doing any REAL coding, I would not suggest using this until it is out of beta. They are busily fixing bugs as we speak. Actually they have a second version of the beta out now, which I have not played with.
Plus I have not run into a browser plug-in for 1.4 yet (although it may be lurking out there).
Michael Bruesch
Ranch Hand

Joined: Sep 23, 2001
Posts: 158
Cindy say wait...I say "How long?". Cindy says jump...I say "How High?". Cindy says I don't download....I say "Not a Prob.". I'm still learning I guess, although I feel I'm more than ready for the SCJP2 test, I just need to come up with the $150! But that's about the extent of my Java knowledge, what will be on the SCJP2 test, when I've passed that (notice I said "when"), should I go ahead and start studying for the SCJD? I want to take that eventually, or should I start someplace else? I know nothing about Servlets, JSPs, JDBC, etc. What are your thoughts Cindy, or some other Java master.
Long live Cindy and Java.

------------------
Michael J Bruesch
Codito, ergo sum...
I code, therefore I am.
http://www.geocities.com/mjbruesch
Cindy Glass
"The Hood"
Sheriff

Joined: Sep 29, 2000
Posts: 8521
The general opionion seems to be split between getting your developers cert and getting the new Web Component Developers cert. I guess it sort of depends on what background that you have.
Then there are also those who are going after a vendor certification. The JCert.org offers several paths including Sun, IBM, Oracle, Bea, Sybase and HP. All of them require you to be a SCJP2 before going on to Step 2.
 
Consider Paul's rocket mass heater.
 
subject: Bug in JDK 1.4
 
Similar Threads
Java 1.4 TextArea
java.util.*;
Use JDK 1.4 / JRE 1.4 on WSAD 5.1.2
JDK 6 and J2EE 1.31 Compatibility
import java.util.Scanner issues