aspose file tools*
The moose likes Beginning Java and the fly likes problem with sdk 1.4 beta and winXP Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "problem with sdk 1.4 beta and winXP" Watch "problem with sdk 1.4 beta and winXP" New topic
Author

problem with sdk 1.4 beta and winXP

Andy Ceponis
Ranch Hand

Joined: Dec 20, 2000
Posts: 782
Im having a problem getting the 1.4 beta to run under XP. I added the path and claspath variables in the right spot, but everytime i go to compile it says it doesnt recognize javac. But if i put the source file in the /java/bin directory then i can compile and run just fine.
Anyone else had any problems like this? I have no clue what is wrong and its annoying.
Thomas Paul
mister krabs
Ranch Hand

Joined: May 05, 2000
Posts: 13974
And the reason you put this in Meaningless Drivel is...?


Associate Instructor - Hofstra University
Amazon Top 750 reviewer - Blog - Unresolved References - Book Review Blog
Valentin Crettaz
Gold Digger
Sheriff

Joined: Aug 26, 2001
Posts: 7610
'cause of the XP thing ?


SCJP 5, SCJD, SCBCD, SCWCD, SCDJWS, IBM XML
[Blog] [Blogroll] [My Reviews] My Linked In
Jim Yingst
Wanderer
Sheriff

Joined: Jan 30, 2000
Posts: 18671
It looks like Valentin has both answered Thomas' question, and diagnosed Andy's problem, in the same post. Well done.
Andy - I don't have XP to test on, so I'm just guessing. Do you get the same message when you type "javac" that you would when you type any unrecognized string, e.g. "javab" or "qwyjibo"? If so, I'd concentrate on the system path rather than class path. But I don't have much else to offer - sorry...


"I'm not back." - Bill Harding, Twister
Paul Stevens
Ranch Hand

Joined: May 17, 2001
Posts: 2823
Moving to Java Beginner. I think there were already some similar discussions on this.
Jim Hall
Ranch Hand

Joined: Nov 29, 2001
Posts: 162
Good one Valentin
Andy Ceponis
Ranch Hand

Joined: Dec 20, 2000
Posts: 782
Thanks Thomas and Valentin. A boatload of help that was. :roll:
Valentin Crettaz
Gold Digger
Sheriff

Joined: Aug 26, 2001
Posts: 7610
Sorry Andy, I couldn't help
Now seriously!
What is the error message exactly ? Sounds like the PATH variable is not set correctly...
Say you have Java installed in C:\>jdk1.4 then the PATH should be
PATH=%WHATEVER%;C:\>jdk1.4\bin
[ January 16, 2002: Message edited by: Valentin Crettaz ]
Andy Ceponis
Ranch Hand

Joined: Dec 20, 2000
Posts: 782
Crap, im stoopid. I forgot to name the path variable. Now it works. Thanks
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: problem with sdk 1.4 beta and winXP
 
Similar Threads
Can I move to J2SE 1.4?
Which API are we using?
Using weblogic.appc from eclipse
problem with 1.4