wood burning stoves 2.0*
The moose likes Beginning Java and the fly likes XP Professional and Class Paths Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "XP Professional and Class Paths" Watch "XP Professional and Class Paths" New topic
Author

XP Professional and Class Paths

Dan Zan
Greenhorn

Joined: Mar 07, 2002
Posts: 6
It seems that I never seem to get pass installing Java on a new operating system without a problem or two.
I followed the instructions provide by sun---going to Control Panel and setting the Enviromental Variables etc. But, no luck, I correctly named my file etc. So, it must be my classpaths. Here is what I have:
C:\j2sdk1.4.0\bin; C:\j2sdk1.4.0\jre\bin; C:\j2sdk1.4.0\lib
The error returned is that it can't find my file.
Even though it is in bin.
Any Ideas
ZanMan
Thomas Paul
mister krabs
Ranch Hand

Joined: May 05, 2000
Posts: 13974
When can't it find the file? When you type it in the console?
Example: >javac
If javac isn't found then the problem is the path not the classpath.


Associate Instructor - Hofstra University
Amazon Top 750 reviewer - Blog - Unresolved References - Book Review Blog
Dan Zan
Greenhorn

Joined: Mar 07, 2002
Posts: 6
Hi There:
Thanks for repling.
I should make a correction the error returned by the compiler is cannot read dan.java.
any further ideas?
Thomas Paul
mister krabs
Ranch Hand

Joined: May 05, 2000
Posts: 13974
Where is Dan.java? You should be running the compile from the directory that Dan.java is in. The classpath is used to find classes, not java source files.
Trent DiBacco
Greenhorn

Joined: May 24, 2002
Posts: 18
add your current directory other wise know in java as the Defualt package to your classpath
CLASSPATH = %CLASSPATH%;. <- this dot indicates current direcoty, the %CLASSPATH% is just my shorthand to what ever you had before.
so basicaly im saying add a dot(. or ./) to your class path.
[ June 07, 2002: Message edited by: Trent DiBacco ]
 
 
subject: XP Professional and Class Paths
 
Similar Threads
Environment Variables for j2sdk1.4.0 & j2re1.4.0-rc
javax.comm problems ! no ports found !
Eclipse - screen - got stucked
javax.comm problem !
error on setting Java_home for Tomcat4.0.3