wood burning stoves*
The moose likes Beginning Java and the fly likes How to compile a file  with J2SE 1.3.1 written in a older version Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "How to compile a file  with J2SE 1.3.1 written in a older version" Watch "How to compile a file  with J2SE 1.3.1 written in a older version" New topic
Author

How to compile a file with J2SE 1.3.1 written in a older version

Mario A. Villamizar
Ranch Hand

Joined: Mar 14, 2002
Posts: 35
Hi, I got some java files written in sdk 1.1 and I've got J2SE 1.3.1. how can I compile then.
many thanks


MA Villamizar
Ron Newman
Ranch Hand

Joined: Jun 06, 2002
Posts: 1056
What problems are you encountering when you compile them with the 1.3.1 compiler? Please be specific.


Ron Newman - SCJP 1.2 (100%, 7 August 2002)
arun mahajan
Ranch Hand

Joined: Dec 07, 2001
Posts: 305
In my opinion there should not be any problem in compiling and running the java class file as java support for the downcompatibility.
Pl specify the problems.
regards,
Arun
Mario A. Villamizar
Ranch Hand

Joined: Mar 14, 2002
Posts: 35
I downloaded some files from the internet, written in swing 1.1 and I trying to compiling that with J2SE 1.3.1 and I got the message that
the package com.sun.java.swing.text.*;
I know that the change thepackage name after that to javax.swing and I try to change it in the java classes that I downloaded but that generate anothers errors.
I downloaded from here http://java.sun.com/products/jfc/tsc/articles/text/editor_kit/index.html
and they give you a hint to compile it but I really don't know how to do it.
thanks
Ron Newman
Ranch Hand

Joined: Jun 06, 2002
Posts: 1056
You need to change every instance of "com.sun.java.swing." to "javax.swing."
Once you do this, what errors are you getting?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: How to compile a file with J2SE 1.3.1 written in a older version
 
Similar Threads
Personal Profile IDE
problem running AdviceClient
CORBA bad operation error in RI
petstore1.3 question
Why "lock" an app to a particluar JRE version