aspose file tools*
The moose likes Beginning Java and the fly likes thin driver / classpath / jdk1.4 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "thin driver / classpath / jdk1.4" Watch "thin driver / classpath / jdk1.4" New topic
Author

thin driver / classpath / jdk1.4

Celinio Fernandes
Ranch Hand

Joined: Jun 28, 2003
Posts: 547

Trying to execute a program, I get the following error:
Exception in thread "main" java.lang.NoClassDefFoundError: "
whenever I set up my CLASSPATH.
export
classpath=/opt/oracle/product/9.2.0/jdbc/lib/ojdbc14.jar:/opt/oracle/product
/9.2.0/jdbc/lib/nls_charset12.zip
javac Test.java ==> ok
java Test == > Exception in thread "main" java.lang.NoClassDefFoundError: "
This is a CLASSPATH problem because if unset the classpath, I don't get any error. So it has nothing to do with the code in my program.
I am using jdk 1.4.1_01 and the jdbc driver is thin (included with Oracle
9i).

Does anyone have an idea ? What is wrong ?
thanks


SCJP 1.4, SCWCD 1.4, SCBCD 1.3, SCBCD 5
Visit my blog
Dirk Schreckmann
Sheriff

Joined: Dec 10, 2001
Posts: 7023
longbeach longbeach,
Welcome to JavaRanch!
We ain't got many rules 'round these parts, but we do got one. Please change your display name to comply with The JavaRanch Naming Policy.
Thanks Pardner! Hope to see you 'round the Ranch!


[How To Ask Good Questions] [JavaRanch FAQ Wiki] [JavaRanch Radio]
Dirk Schreckmann
Sheriff

Joined: Dec 10, 2001
Posts: 7023
Perhaps you need to include the current working directory in your CLASSPATH setting. The current working directory is denoted with a period. So, your CLASSPATH should be
.:[OTHER LOCATIONS HERE]
[ June 29, 2003: Message edited by: Dirk Schreckmann ]
bharat nagpal
Ranch Hand

Joined: Oct 26, 2002
Posts: 76
you need to ser the classpath of your system to include the jar files in JDK.
just write on the command prompt
set CLASSPATH=e:\jdk1.4\lib\nameofJar.jar;%CLASSPATH%;.;
where e:\jdk1.4 (is your java_home) and nameofJar is name os jar files in lib directory under java_home. Include all the jar files one by one.
it will work for you.
If everything goes well. Modify the classpath settings and reopen a new command prompt.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: thin driver / classpath / jdk1.4