Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

newbie here, help

 
Larry Brink
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Good day to all. I am just starting out with Java, I am taking class at a local college, actually for Web Analyst/Programmer. But any way, I did have the j2sdk1.4.1 installed on my computer, our instructor advised us that we will be using a program called BlueJ. After installing BlueJ I can not compile any thing at all from the command prompt, I get the message:
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.
D:\Documents and Settings\OURS>cd
D:\Documents and Settings\OURS
D:\Documents and Settings\OURS>A:
A:\>javac Tree1.java
'javac' is not recognized as an internal or external command,
operable program or batch file.
A:\>
Ok, so now what is wrong. What I did was completely uninstall the j2sdk1.4.1. and BlueJ. Reinstalled j2sdk1.4.1 and I get the same exact message. Below is what is set in the Enviroment variables on my computer.
(This is what is set in the Enviroment Variables
Enviroment Variables
VariableValue
CLASSPATH D:\j2sdk1.4.1\bin\;.;
Variable nameVariable Value
PathD:\j2sdk1.4.1\bin\;.;
Now of course there is more to the Path Variable then what is shown above, but what you see abouve for the Path is added to the end of the Path. Any suggestions as to what I might try next. Please.
Thank You in advanced for any and all help from this message board. I have a feeling I will be visiting here quite often.
Larry
 
chi Lin
Ranch Hand
Posts: 348
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Larry,
I think you could modify your classpath setting
.;D:\j2sdk1.4.1\lib\tools.jar
Originally posted by Larry Brink:

VariableValue
CLASSPATH D:\j2sdk1.4.1\bin\;.;
 
Ernest Friedman-Hill
author and iconoclast
Marshal
Pie
Posts: 24211
35
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
While it's true that there's no point in having {JDKHOME}/bin on your CLASSPATH, there's also no reason for a beginner to have {JDKHOME}/lib/tools.jar on his CLASSPATH, either. A beginner should, generally, start with CLASSPATH not set at all -- the default behavior is fine.
In any case, the problem has to be one of the following:
  • There's no JDK installed at d:\j2sdk1.4.1\, or
  • The entry for this directory in the PATH variable isn't quite right, or the path is generally munged in some way, or
  • The command window doesn't "see" the PATH shown in the Control Panel. Changes to environment variables or don't affect command windows or application that were open previous to the change; you generally have to open a new command window to get the new variables.
  •  
    Marilyn de Queiroz
    Sheriff
    Posts: 9065
    12
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Look in D:\j2sdk1.4.1\bin\ and see if the javac.exe file is really there.
     
    Larry Brink
    Greenhorn
    Posts: 4
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Thanks to all that posted. I do finaly have it working, my settings were all correct, j2sdk1.4.1 is installed, I just seem to have a problem reading files from a certain removable disk, why I don't know that yet, but I will soon. At least I can now get down to learning this language. Again thanks to every one. Just hope it wasn't a dump question in the first place.
    Larry
     
    • Post Reply
    • Bookmark Topic Watch Topic
    • New Topic