File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Beginning Java and the fly likes Java won't run Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "Java won Watch "Java won New topic

Java won't run

Atrus Greyor
Ranch Hand

Joined: Mar 07, 2004
Posts: 110
When I try to run ANY compiled works I get this error message:

Registry key 'Software\JavaSoft\Java Runtime Environment\CurrentVersion'
has value '1.3', but '1.4' is required.
Error: could not find java.dll
Error: could not find Java 2 Runtime Environment.

This even appears even when I try to run already compiled source.
I have Java SDK 1.4.2 and this error makes no sense to me. What should I do???
Alain Boucher
Ranch Hand

Joined: Feb 25, 2003
Posts: 51
Format your PC and Install Linux!!!

1- Uninstall java from your machine
2- Run regedit
3- Search for any java tag (remove them)
4- Reinstall java 1.4
5- add <INSTALLDIR_JAVA14>\bin in your path
6- open command prompt
7- type "java -version"

Alain Boucher<br />Spare-Brain Consultants Inc.<br />SCJ2P,SCWCD,
Marilyn de Queiroz

Joined: Jul 22, 2000
Posts: 9058

I agree with steps 1 through 7. I've done it myself and for the same reason.

"Yesterday is history, tomorrow is a mystery, and today is a gift; that's why they call it the present." Eleanor Roosevelt
Shashank Agarwal
Ranch Hand

Joined: May 20, 2004
Posts: 105
Hey Atrus, which Operating System are you using. You might want to try and set path to JDK1.4. This problem bugged me when i upgraded from jdk 1.2 to 1.3 but forgot to change the path.

All the best.
Dirk Schreckmann

Joined: Dec 10, 2001
Posts: 7023

You might have success by uninstalling all JREs and JDKs on your computer, restarting, then installing the JRE/JDK you want to use.

[How To Ask Good Questions] [JavaRanch FAQ Wiki] [JavaRanch Radio]
I agree. Here's the link:
subject: Java won't run
It's not a secret anymore!