*
The moose likes Beginning Java and the fly likes java 5.0 and Array Lists Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "java 5.0 and Array Lists" Watch "java 5.0 and Array Lists" New topic
Author

java 5.0 and Array Lists

Eric Grant
Greenhorn

Joined: Nov 23, 2005
Posts: 2
I am using the current version of Java (5.0, or 1.5) and am trying to use an array list. I am getting an error saying that the source is not Java 5.0 and I need to use it, but I am using Java 5.0. Is there a setting I need to change? I never had any other version of Java on my computer.
Thank you for your time and effort.
marc weber
Sheriff

Joined: Aug 31, 2004
Posts: 11343

Welcome to JavaRanch!

It sounds like you're using an IDE. If so, which one are you using?

(In Eclipse 3.1 on the Mac, for example, there is a setting under Preferences / Java / Compiler to specify a Java version for "source compatability.")


"We're kind of on the level of crossword puzzle writers... And no one ever goes to them and gives them an award." ~Joe Strummer
sscce.org
Eric Grant
Greenhorn

Joined: Nov 23, 2005
Posts: 2
Thank you for your help. I found the setting and it worked.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: java 5.0 and Array Lists
 
Similar Threads
el-ignored query
Not able to execute a sample jsp file
Can I use Java 5.0 for the SCJD and start now?
help me to solve java.rmi.UnmarshalException
generic DAO giving error... why?