Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

java problem

 
sukumar chellakannu
Greenhorn
Posts: 4
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi iam using jdk1.5 ,i have worked with java programs previously..
now if try to run any programs iam getting an exception like this,


Exception in thread "main" java.lang.UnsupportedClassVersionError: TestEx (Unsupported major.minor version 49.0)

can anyone solve this please?
 
tim bond
Greenhorn
Posts: 18
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
please uninstall both the jdk 1.5 and the previous versions of jdk that you have installed. restart the system and then install only the jdk 1.5.
also check the path and classpath in environment variables of the device manager.
 
Sri Ram
Ranch Hand
Posts: 118
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
U dont need to uninstall both the jre. U have have multiple versions of JRE in ur System with out any problem

This exception can occur when the source is built targeting a JDK that is not supported by the JDK attempting to run it or the other way. In the above example, if the servlet was built targeting only JDK 1.5, but the web server runs JDK 1.4, the above exception will occur.

Check, Project Properties | Build | Java | Target VM, and verify that the Target VM indicates a JDK compatibility that is appropriate for the JDK that is running it.
 
Adam Richards
Ranch Hand
Posts: 135
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tip: Try to use more specific subject lines. The more meaningful your subject, the more meaningful your replies.
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic