aspose file tools*
The moose likes Beginning Java and the fly likes Ports going crazy... Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "Ports going crazy..." Watch "Ports going crazy..." New topic
Author

Ports going crazy...

Vinnie Jenks
Ranch Hand

Joined: Apr 26, 2004
Posts: 207
I'm having a really rough time getting JBoss to run correctly due to ports being consumed.

I'm on Windows XP SP2, using eclipse 3.1.2 + MyEclipse 4.1.1. I'm using JBoss 4.0.4RC1 w/ EJB3 (non-clustered).

I've been writing and testing apps on JBoss for a week now in this environment w/o a single problem. Suddenly, I can't get JBoss to start w/o a boatload of exceptions due to ports already being in use.

First it was port 1101....now I'm having problems w/ 1098...so JNDI won't work apparently...



I have no idea what is suddenly using these ports or what is going on...anyone have any ideas? I tried using netstat and that just shows me that the ports are in use...doesn't help much.

Thanks!
Ernest Friedman-Hill
author and iconoclast
Marshal

Joined: Jul 08, 2003
Posts: 24187
    
  34

Most likely it's due to previous instances of JBoss that haven't fully shut down. Just reboot.


[Jess in Action][AskingGoodQuestions]
Ernest Friedman-Hill
author and iconoclast
Marshal

Joined: Jul 08, 2003
Posts: 24187
    
  34

Most likely it's due to previous instances of JBoss that haven't fully shut down. Just reboot.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Ports going crazy...