An array of double is not an array of Objects, because doubles aren't Objects. The only way to convert an array of double into an array of Double (the wrapper class) is to create an entirely new array of the right size and then, in a loop, create a Double for each double value and store it in the array.
Having an array which itself contains other arrays of different kinds is Highly Unusual, and I suspect rather strongly that you could avoid the whole question by improving your design. For example, support the Object were replaced by an instance of a class of your own devising which had two Strings and a double as members? That class could have a getStringArray1(), getStringArray2(), and getDoubleArray() methods which returned those members, and all the code would be much easier to follow because the confusing casts were not necessary. You could even use vastly more informative names for these methods -- I only used these silly names because I don't know what your data represents.
Zintan, I strongly agree with Ernest - what you are doing sounds like it could be much better done with a different design. If you'd like to explore that, please tell us more about what you are trying to accomplish...
The soul is dyed the color of its thoughts. Think only on those things that are in line with your principles and can bear the light of day. The content of your character is your choice. Day by day, what you do is who you become. Your integrity is your destiny - it is the light that guides your way. - Heraclitus