aspose file tools*
The moose likes Beginning Java and the fly likes about JVM version Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "about JVM version" Watch "about JVM version" New topic
Author

about JVM version

ravindra patil
Ranch Hand

Joined: Sep 01, 2006
Posts: 214
i want to installed eclipse WTP but when i click on exe file it shows box showing jvm version required 1.4 or greater i have jdk 1.4.2 then i don't know why it is giving error but when i give command c:\> java -version it shows jdk 1.3 so what is the problem
Jesper de Jong
Java Cowboy
Saloon Keeper

Joined: Aug 16, 2005
Posts: 13868
    
  10

Do you have Oracle software installed on your machine?

Oracle has the bad habit of supplying a Java version 1.3 JRE with their software. Check the setting of the PATH environment variable. Make sure that you remove the Oracle JRE from the PATH, and make sure that the bin directory your Java 1.4.2 JDK is in the PATH.

For instructions on setting the PATH, see the JDK installation notes (step 5 explains how to set the PATH).


Java Beginners FAQ - JavaRanch SCJP FAQ - The Java Tutorial - Java SE 7 API documentation
Scala Notes - My blog about Scala
Rahul Bhattacharjee
Ranch Hand

Joined: Nov 29, 2005
Posts: 2308
look at the PATH system variable..Before it gets to the jvm 1.4 it finds jvm 1.3.x .That is the reason.Two jdk installations's bin are in PATH i suspect.


Rahul Bhattacharjee
LinkedIn - Blog
ravindra patil
Ranch Hand

Joined: Sep 01, 2006
Posts: 214
Originally posted by ravindra patil:
i want to installed eclipse WTP but when i click on exe file it shows box showing jvm version required 1.4 or greater i have jdk 1.4.2 then i don't know why it is giving error but when i give command c:\> java -version it shows jdk 1.3 so what is the problem


thanks Mr. young i removed that oracle path setting and very happy because now it is showing 1.4
ravindra patil
Ranch Hand

Joined: Sep 01, 2006
Posts: 214
Originally posted by ravindra patil:
i want to installed eclipse WTP but when i click on exe file it shows box showing jvm version required 1.4 or greater i have jdk 1.4.2 then i don't know why it is giving error but when i give command c:\> java -version it shows jdk 1.3 so what is the problem


thanks Mr. young i removed that oracle path setting and very happy because now it is showing 1.4
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: about JVM version
 
Similar Threads
How to detect the JVM version of the browser like IE or Netscape navigator?
Problem with running my class inside ANT
Applet - ie5 version problem
JVM TERMINATED with Exit Code=1
Unsupported major.minor version 50.0