Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Installing java and putting it in the Path variable.

 
Scott Pike
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I read the instructions and installed java, then I tried to add the java binto the path , but when I tried to use the program to test my file, it didn't recognize the javac command as anything. I'm a total beginer at java and don't really know how to add the path to the java program. Please help.
 
Nathan Leniz
Ranch Hand
Posts: 132
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi there, welcome to Java Ranch!

There are lots of other posts up regarding installing Java and configuring your path. I did a search and this one looks pretty good.

If you have other problems, post where your java folders are located on your machine and also it may help to post your path variable. Feel free to ask more questions as you need, that's what this place is all about.

Nate
[ January 28, 2007: Message edited by: Nathan Leniz ]
 
marc weber
Sheriff
Posts: 11343
Java Mac Safari
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to JavaRanch!

Please tell us the full path of where you installed Java, and copy and paste your full PATH variable here. Also tell us what operating system you're using.
 
Scott Pike
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I installed my java in the my C:\Program Files\Java\jdk1.5.0_10\bin
As for the Path. I'm not sure if I found the right one when I tried to put it there. it was in the environment variables.
here it is: %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files\ATI Technologies\ATI.ACE\;C:\Program Files\Common Files\Roxio Shared\DLLShared\;%JAVA_HOME%\bin;C:\Program Files\QuickTime\QTSystem\
This might be from the last time I tried to install java for my class. :roll:
 
marc weber
Sheriff
Posts: 11343
Java Mac Safari
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try adding C:\Program Files\Java\jdk1.5.0_10\bin to the end of your existing PATH. Be sure to separate this new entry with a semicolon, but no spaces. Your new PATH should look like this...

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files\ATI Technologies\ATI.ACE\;C:\Program Files\Common Files\Roxio Shared\DLLShared\;%JAVA_HOME%\bin;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\Java\jdk1.5.0_10\bin

After setting this, reboot.
 
Jan Cumps
Bartender
Posts: 2588
11
C++ Linux Netbeans IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Scott Pike:
...Shared\DLLShared\;%JAVA_HOME%\bin;C:\...


It's the %JAVA_HOME% setting that is giving you problems.

If the PATH variable is set before the JAVA_HOME variable, it will never be translated to your java installation,
even if your JAVA_HOME variable is set correctly.

Replace it with the actual location of your java bin directory.

Regards, Jan
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic