hello friends ..I am apperaring for java 1.5 ..i have 1.4 installed do i need to install 1.5 to run all the codes of generics,enum etc which are not in 1.4..do i need to uninstall 1.4 before installing 1.5.
To use generics and enums, you need Java 5 (aka JDK 1.5). You can ask the Java 5 compiler to produce code that will run on Java 1.4; use "-target 1.4". However, note that if you use any API classes that are not present in Java 1.4, this will not help with that.
You can happily have lots of versions of Java installed all at once. I have 1.1, 1.4 and 6 at the moment. Only one can be the default Java in your Web browser, but that's mostly not relevant to Java application development.
If you do have multiple versions installed, you must take care which one you invoke; either use the full path to commands like "java" and "javac" or adjust your PATH variable when switching versions.
Betty Rubble? Well, I would go with Betty... but I'd be thinking of Wilma.