wood burning stoves*
The moose likes Beginning Java and the fly likes Incompatible JVM error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "Incompatible JVM error" Watch "Incompatible JVM error" New topic
Author

Incompatible JVM error

Rajesh Mani
Greenhorn

Joined: May 12, 2007
Posts: 6
Am trying to use Eclipe IDE. When i try to open it get the error message as "Version 1.4.2_06 of the JVM is not suitable for this product. Version:1.5 or greater is required". Please help in configuring the path and opening the eclipse.

Thanks,
Rajesh.
Daesung Park
Ranch Hand

Joined: Mar 22, 2007
Posts: 68
If your Eclipse version is europa, you need Java 5 JRE. If you already installed the JRE, you can specify JRE version to launch eclipse.
Refer to THIS.


Daesung Park

BLOG
Ahmad Shahir Ramly
Greenhorn

Joined: Jun 25, 2010
Posts: 1
1)Download jdk-6u20-windows-i586
2)Install jdk-6u20-windows-i586
3)To make sure that Windows can find the Java compiler and interpreter:
• Select Start -> Computer -> System Properties -> Advanced system settings -> Environment Variables -> System variables -> Path.
• [ In Vista, select Start -> My Computer -> Properties -> Advanced -> Environment Variables -> System variables -> PATH. ]
• [ In Windows XP, Select Start -> Control Panel -> System -> Advanced -> Environment Variables -> System variables -> PATH. ]
• [ In Windows 7, Select Start -> Control Panel -> System -> Advanced system settings -> Environment Variables -> System variables -> PATH. ]
4)Paste C:\Program Files\Java\jdk1.6.0_20\bin; to the beginning of the Variable value
5)Click OK
6)This could solve your problem very well.

Please read my article on how to install How to Install Eclipse Ide for Java Developers http://computersight.com/programming/how-to-install-eclipse-ide-for-java-developers/



- Solution provided by virtualredheart -
Jesper de Jong
Java Cowboy
Saloon Keeper

Joined: Aug 16, 2005
Posts: 14114
    
  16

"cae virtualredheart", welcome to JavaRanch. Please check your private messages for an administrative message from JavaRanch.


Java Beginners FAQ - JavaRanch SCJP FAQ - The Java Tutorial - Java SE 7 API documentation
Scala Notes - My blog about Scala
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Incompatible JVM error