aspose file tools*
The moose likes Beginning Java and the fly likes cannot access javax.ejb.EJBException Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "cannot access javax.ejb.EJBException" Watch "cannot access javax.ejb.EJBException" New topic
Author

cannot access javax.ejb.EJBException

dale conn
Ranch Hand

Joined: Jun 16, 2006
Posts: 57
Hi all,

I'm trying to compile some code and i get the following error:
cannot access javax.ejb.EJBException

file javax\ejb\EJBException.class not found
try
^

that's it

Can anyone tell me what I can do / look at to fix it?

thanks for any help
Campbell Ritchie
Sheriff

Joined: Oct 13, 2005
Posts: 36555
    
  16
You will probably have to download J2EE to get that particular Exception.
dale conn
Ranch Hand

Joined: Jun 16, 2006
Posts: 57
i can compile using jdk 1.4 and it's fine

but i'm trying tp upgrade to 1.5 and it fails



i don't have j2ee installed - why would i have to download it to get it to work?
Bill Shirley
Ranch Hand

Joined: Nov 08, 2007
Posts: 457
Originally posted by dale conn:
i can compile using jdk 1.4 and it's fine

but i'm trying tp upgrade to 1.5 and it fails



i don't have j2ee installed - why would i have to download it to get it to work?


javax.ejb.* is not part of the Standard JDK (part of Java SE), it's part of Java EE,

Standard Edition v Enterprise Edition


Bill Shirley - bshirley - frazerbilt.com
if (Posts < 30) you.read( JavaRanchFAQ);
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: cannot access javax.ejb.EJBException
 
Similar Threads
Please help !!!!!!!!!!!
RemoteException vs EJBException
SCWCD links broken
EJB using Jboss-IDE 1.6
Application Exception