File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Beginning Java and the fly likes Need the IBM JRE Version Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "Need the IBM JRE Version" Watch "Need the IBM JRE Version" New topic

Need the IBM JRE Version

Swapna Mandava

Joined: Feb 05, 2008
Posts: 6

When I type java -version as follows, it displays the following information.
Can any one please tell me what version of IBM JRE is used for this?
I belive it is IBM J9 2.3
but not sure...I need to download the same version that was used in the below information.

-bash-3.00$ java -version
java version "1.5.0"
Java(TM) 2 Runtime Environment, Standard Edition (build pap64devifx-20070323 (ifix 117670: SR4 + 116644 + 114941 + 116110 + 114881))
IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 AIX ppc64-64 j9vmap6423ifx-20070323 (JIT enabled)
J9VM - 20070322_12058_BHdSMr
JIT - 20070109_1805ifx3_r8
GC - WASIFIX_2007)
JCL - 20070126

Thanks in advance,
Campbell Ritchie

Joined: Oct 13, 2005
Posts: 46373
Do you really need an IBM java runtime? Won't any Java 5 runtime work?
I agree. Here's the link:
subject: Need the IBM JRE Version
It's not a secret anymore!