This week's giveaway is in the Spring forum.
We're giving away four copies of REST with Spring (video course) and have Eugen Paraschiv on-line!
See this thread for details.
The moose likes EJB and other Java EE Technologies and the fly likes Strange EJB3 MDB Problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Strange EJB3 MDB Problem" Watch "Strange EJB3 MDB Problem" New topic

Strange EJB3 MDB Problem

Sunil Huilgol

Joined: Jan 22, 2006
Posts: 8
I am using jboss4.0.5.GA.
I have a mdb which is bound to a queue. This queue is already having some messages lying which i could see in the jboss web-console. The queue depth was set to 11. But somehow the mdb is not processing these messages. I have put a println statement in my onmessage and even that did not print on console.
I verified if the queue name i have mentioned in my code file is the same as of the one whose depth was set and that is ok.
This is very strange as i have never seen this happen. There is no error on jboss console on in my logs.I would appreciate if someone can help me here.
Sunil Huilgol

Joined: Jan 22, 2006
Posts: 8
Please disregard my above post as it WAS a queue name issue.
However I did see a Communication issue in my log saying "Could not connect to localhost:1100". Possibly that was the reason the mdb did nor start up as the queue request had a comminication issue.
I agree. Here's the link:
subject: Strange EJB3 MDB Problem
It's not a secret anymore!