Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Authentication using an MDB towards an external JMS provider

 
Giorgio Giannotti
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all.
Please consider the following problem: I have a Message Driven Bean running in Weblogic 6.1 (this is a project requirement, so I cannot change the release for now) and connecting to a JMS queue configured not in WebLogic itself, but provided by a Tibco EMS server properly configured on the host machine.
As first step, the MDB was properly configured and deployed, so the connection with the needed queue went well and the messages produced on the queue were correctly listened and read. The second step consisted in authentication and authorization, and here is the point at which problems raised: although I think I have correctly followed the generally stated rules to make the MDB present itself as run by a certain user (also configured in the WebLogic as well as Tibco servers) according to the declarative way (that is, acting only on the Deployment Descriptor and not directly from the implementing code), the Tibco log shows a connection attempt by the user "anonymous" (i.e. a not recognized user), which is therefore denied any access to the configured queues. Note that, when I try to access the same queues with a simple client application, which directly uses the createQueueConnection(String, String) method and passing the same credentials, the Tibco server recognizes the correct user and allows message sending and/or receiving...
I suppose I am misunderstanding the correct use of the tags in the descriptors (ejb-jar.xml and weblogic-ejb-jar.xml) but, although I tried various combinations and configurations (you know: when things don't work properly, one is prone to apply variations and unlikely intuitions!), I couldn't get any good result: the weblogic log simply states that the queue configured in the MDB descriptor cannot be reached (but this is false, because when authentication is disabled on Tibco the queue is correctly seen and accessed) and, as told before, the Tibco log sees access from the user anonymous.
Please, has anyone faced a similar problem?

Thanks

Giorgio
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic