This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes JDBC and the fly likes ORA-12541: TNS:no listener....Please Help Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Databases » JDBC
Bookmark "ORA-12541: TNS:no listener....Please Help" Watch "ORA-12541: TNS:no listener....Please Help" New topic
Author

ORA-12541: TNS:no listener....Please Help

Aman Gupta
Greenhorn

Joined: Nov 12, 2008
Posts: 10
Hi,

I have 2 databases on different machines - ORCL on 172.21.161.107 and scmb10g on 172.21.161.60.
I tried to create a database link from ORCL on 172.21.161.107 to scmb10g on 172.21.161.60.
The public db link is created successfully....but while trying to access it, I'm getting foll error .

Please Help.



SQL> create public database link fsnew10 connect to onsitedba identified by onsitedba using '(DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = 172.21.161.60)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = SCMB10g) ) )';

Database link created.

SQL> commit;

Commit complete.

SQL> select * from SYG_SYSTEM_GLOBALS@fsnew10;
select * from SYG_SYSTEM_GLOBALS@fsnew10
*
ERROR at line 1:
ORA-12541: TNS:no listener
Rene Larsen
Ranch Hand

Joined: Oct 12, 2001
Posts: 1179

I think that you need to use the SERVICE_NAME, that you set up with the network config tool.

The syntax for creation of a database link is:

[ November 26, 2008: Message edited by: Rene Larsen ]

Regards, Rene Larsen
Dropbox Invite
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: ORA-12541: TNS:no listener....Please Help
 
Similar Threads
JDBC connection issue with RAC database
how to recover - corrupted "undotbs01.dbf " ?
Could not create connection; - nested throwable:
ORA-12541: TNS:no listener.....Please help
Error in connecting weblogic 6.1 and oracle..plz help me