wood burning stoves 2.0*
The moose likes Applets and the fly likes when applet runs in browser ocnnection is lost. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Java » Applets
Bookmark "when applet runs in browser ocnnection is lost." Watch "when applet runs in browser ocnnection is lost." New topic
Author

when applet runs in browser ocnnection is lost.

P Kulkarni
Greenhorn

Joined: Dec 10, 2008
Posts: 8
Hello all,

I am using Redhat 5.2 and Firefox 3.0

When I run application for particular scenario that is when I create a web page(one option in my project)some part of the applet on the browser becomes gray and connection is lost. When I re-enter everything goes fine.
Only for the first I am facing that problem.

I am getting following exceptions :

java.lang.InterruptedException
at java.lang.Object.wait(Native Method)
at XYZ.package1.class1.run(ClientConnection.java:514)

Application is working fine on Java 1.6 update 1 to 3 and update 10 with respective plugin for FireFox. It also works on 1.5 all updates.

Can someone help me out??

Thanks
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42374
    
  64
Since you mention various JVM versions for which this works, which is the one that doesn't work?

What's the code doing around line 514 of class ClientConnection?


Ping & DNS - my free Android networking tools app
P Kulkarni
Greenhorn

Joined: Dec 10, 2008
Posts: 8
Hi,

These are more details.

it does not work for java 1.6 update 4 to 7.
And it also works fine on other browser Opera, Safari.

Actualy it is a part of a big project i am not able to disclose the code because of the security reasons.

Can you please tell me is this common bug because in many forums I saw same exceptions and applet graphics does not get completely painted in the browser, it becomes gray.


Thanks!
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42374
    
  64
It's hard to diagnose code one doesn't see.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: when applet runs in browser ocnnection is lost.