aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Debugging Tomcat application using Eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Debugging Tomcat application using Eclipse" Watch "Debugging Tomcat application using Eclipse" New topic
Author

Debugging Tomcat application using Eclipse

Ankit Garg
Sheriff

Joined: Aug 03, 2008
Posts: 9321
    
  17

Hi! I have a problem. I want to create a web application in eclipse and want to debug it directly from Eclipse. For that I downloaded Eclipse-Tomcat plug-in from here.

Then I created a new Tomcat project in eclipse. But when I try to run or debug the project, Run on Server option is not available. When I create a normal web application, then an option to run it on server is there, but when I click on it, I get an error

The Tomcat server configuration at \Server\Tomcat v6.0 Server at localhost-config is missing. Check the server for errors.


Also it shows Tomcat as stopped while it is running. I also used catlina jpda start command so that tomcat runs in debugging mode. I have also created JPDA_ADDRESS and JPDA_TRANSPORT environment variables. But still the problem persists. Can anyone help me in this regard. I am using Eclipse 3.4 and Tomcat 6.0..

I would be very thankful if anyone solves my problem... :roll:
[ November 04, 2008: Message edited by: Ankit Garg ]

SCJP 6 | SCWCD 5 | Javaranch SCJP FAQ | SCWCD Links
Ankit Garg
Sheriff

Joined: Aug 03, 2008
Posts: 9321
    
  17

Please someone help me on this :roll:
Paul Michael
Ranch Hand

Joined: Jul 02, 2001
Posts: 697
Can you check from your workspace if you accidentally closed the "Servers" project?

From the error message you posted, the "Servers" folder would be the first place I'd look into.

I'm not very familiar with the Tomcat Plugin but I've had good results with using just WTP and the built in debugger.

I'll try to look for tutorials first regarding that approach so I can post it here.


SCJP 1.2 (89%), SCWCD 1.3 (94%), IBM 486 (90%), SCJA Beta (96%), SCEA (91% / 77%), SCEA 5 P1 (77%), SCBCD 5 (85%)
Paul Michael
Ranch Hand

Joined: Jul 02, 2001
Posts: 697
Try this.
Ankit Garg
Sheriff

Joined: Aug 03, 2008
Posts: 9321
    
  17

Actually I am new to Eclipse. So I don't know much. I have already tried the page you gave Paul. So now I am reading a book on Eclipse. I think that will clear all my doubts..

Anyway thanks for your time Paul
Paul Michael
Ranch Hand

Joined: Jul 02, 2001
Posts: 697
You're most welcome.
Niju Thomas
Greenhorn

Joined: Jul 29, 2011
Posts: 13
Actually there was a small mistake.there was a folder name as "Servers" in the project explorer..just open that and problem will solve..
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Debugging Tomcat application using Eclipse