• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Build Error In creating new project in Maven

 
Manish Doomra
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all,

I am referring the book 'Better Build with Maven'

For creating my first project in maven, I am passing this command


But it is giving the following build error:-

[INFO] Scanning for projects...
[INFO] Searching repository for plugin with prefix: 'archetype'.
[INFO] org.apache.maven.plugins: checking for updates from central
[WARNING] repository metadata for: 'org.apache.maven.plugins' could not be retrieved from repository: centr
al due to an error: Error transferring file
[INFO] Repository 'central' will be blacklisted
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] The plugin 'org.apache.maven.plugins:maven-archetype-plugin' does not exist or no valid version coul
d be found
[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 21 seconds
[INFO] Finished at: Sat Nov 08 18:21:44 IST 2008
[INFO] Final Memory: 12M/64M
[INFO] ------------------------------------------------------------------------


I have downloaded and installed using the instructions given on:-
http://maven.apache.org/download.html

PS:But I have not made any changes in settings.xml
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you behind a firewall? You might have to configure Maven to use proxy. See this guide
 
Manish Doomra
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you behind a firewall? You might have to configure Maven to use proxy. See this guide


Thanks Jai, It worked fine

For others, who face the same situation, optional tags are commented out in configuration file(settings.xml).

After Changing parameters make sure you uncomment the tags (First time I also missed it)
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic