aspose file tools*
The moose likes BEA/Weblogic and the fly likes NodeManager problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "NodeManager problem" Watch "NodeManager problem" New topic
Author

NodeManager problem

alds orteza
Greenhorn

Joined: Nov 17, 2008
Posts: 9
Hi,

Im having trouble starting my managed server. This is the error that occurs:

SecureCommandInvoker: Could not create a socket to the NodeManager running on host 'localhost:5555' to execute command 'online server1', reason: Connection refused: connect. Ensure that the NodeManager on host 'localhost' is configured to listen on port '5555' and that it is actively listening

How can I configure the NodeManager to listen on port 5555? Any help is greatly appreciated. Thanks in advance.

Aldrin
Andrea Gazzarini
Ranch Hand

Joined: Sep 09, 2002
Posts: 125
Hi alds, it seems strange because the node manager listens by default on localhost:5555...
Sorry for the stupid questions but : did you start the node manager? ($WL_HOME/server/bin/startNodeManager(.sh | .cmd)


Regards,<br />Andrea<br /> <br /><a href="http://www.linkedin.com/in/andreagazzarini" target="_blank" rel="nofollow">Andrea Gazzarini</a><br />Skype ID : gazzax72<br />Google Talk ID : a.gazzarini@gmail.com<br /><a href="http://www.andreagazzarini.blogspot.com" target="_blank" rel="nofollow">My Blog</a>
alds orteza
Greenhorn

Joined: Nov 17, 2008
Posts: 9
Hi Andrea,

Yes I did start it. At the end of the prompt was this:

<Nov 19, 2008 9:07:52 PM PST><Info><NodeManager@*.*:5555><NodeManager started, log messages being written into file C:\DEV\Tools\Bea\weblogic81\server\bin\NodeManagerLogs\NodeManagerInternal\nm_mycomputer_11_19_2008-21_07_49.log>

This is the log:

<Nov 19, 2008 8:55:28 PM PST> <Info> <NodeManager> <Starting Node Manager...>
<Nov 19, 2008 8:55:28 PM PST> <Info> <NodeManager> <For information on command line options, try "weblogic.NodeManager help"".>
<Nov 19, 2008 8:55:31 PM PST> <Info> <NodeManager@mycomputer:5555> <Reading private key and certificate chain from the keystore C:/DEV/Tools/Bea/WEBLOG~1/server\lib\DemoIdentity.jks. KeyStore type = jks, Using keystore passphrase = true, Alias = DemoIdentity>
<Nov 19, 2008 8:55:31 PM PST> <Info> <NodeManager@mycomputer:5555> <Reading trusted CAs from the keystore C:/DEV/Tools/Bea/WEBLOG~1/server\lib\DemoTrust.jks. KeyStore type = jks, Using keystore passphrase = true>
<Nov 19, 2008 8:55:31 PM PST> <Info> <NodeManager@mycomputer:5555> <Reading trusted CAs from the keystore C:\DEV\Tools\Bea\JDK141~1\jre\lib\security\cacerts. KeyStore type = jks, Using keystore passphrase = false>
<Nov 19, 2008 8:55:31 PM PST> <Info> <NodeManager@mycomputer:5555> <SecureSocketListener: Enabled Ciphers >
<Nov 19, 2008 8:55:31 PM PST> <Info> <NodeManager@mycomputer:5555> <TLS_RSA_EXPORT_WITH_RC4_40_MD5>
<Nov 19, 2008 8:55:31 PM PST> <Info> <NodeManager@mycomputer:5555> <SecureSocketListener: listening on mycomputer:5555..>

What do you think is the problem? Thanks in advance.
Andrea Gazzarini
Ranch Hand

Joined: Sep 09, 2002
Posts: 125
Hi, I think that the listen address is mycomputer and not localhost. If you open the wls console you can configure node manager properties. try to replace "localhost" with "mycomputer"

Alternatively you can start node manager on localhost using

> startNodeManager localhost 5555
alds orteza
Greenhorn

Joined: Nov 17, 2008
Posts: 9
Hi Andrea,

I did what you told me to do. When I started my managed server. I takes a long time to finish and when it did, it still failed. Here is the error:

[The request to start the server myserver of domain mydomain failed because the node manager did not hear from the managed server in the configured timeout period. Despite this, if the managed server has not failed, it will come up and the node manager will start monitoring it. To adjust this timeout so that the task does not fail prematurely, please refer to the node manager property ScavangerDelaySeconds (Default value : 180 seconds. Current value : 180 seconds).]

I was under the impression when you start the weblogic server, both the admin server and the managed server starts at the same time. Am I right? If I am, why does my managed server needs to be manually started? Thanks in advance.

Aldrin
Ian Anderson
Greenhorn

Joined: Nov 20, 2008
Posts: 2
Weblogic Admin server, managed server and node manager are three seperate processes that are started by independant scripts (by default)

When you start the admin server using startWeblogic.sh it only starts the admin server.

To start node manager you use
<BEA_ROOT>/wlserver_10.0/server/bin/startNodeManager.sh

Starting a managed server used startManagerServer.sh.

Make sure your firewall on the remove node is not blocking port 5555
Andrea Gazzarini
Ranch Hand

Joined: Sep 09, 2002
Posts: 125
Hi, just a little thing : there's no admin & managed server...simply the first server that is running is targeted as admin server.
Ian Anderson
Greenhorn

Joined: Nov 20, 2008
Posts: 2
I don't think that is right. Managed servers need to communicate with the admin server. If the admin server was based upon whatever managed server was started first, your admin server would continually change. Add to that, that nodemanager needs to point to an admin server. The ip adddress/hostname is called out in the nodemanager configuration file.

The admin server is what has the console app which allows you to administer the weblogic cluster. I realize that the admin server is nothing more than a stripped down managed server, but there is still a distinction.....at least in wls10.
Joe Rosiak
Greenhorn

Joined: May 21, 2008
Posts: 7
The nodemanager shouldn't require an admin server. The admin server requires the nodemanager to communicate with the managed servers.

One thing I found when setting up the nodemanager was that I had to have the hosts fully qualified name listed in the nodemanage setup.

Example:
Log into the admin console.
Go to Machines
click on the machine you want to configure nodemanager for.
In the listen address field type: foo.foobar.com

This is how I got it to work with weblogic 9


Respectfully Yours,
Joe Rosiak
 
Consider Paul's rocket mass heater.
 
subject: NodeManager problem