aspose file tools*
The moose likes Websphere and the fly likes  SRVE0255E: A WebGroup/Virtual Host to handle /ApplicationName has not been defined Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark " SRVE0255E: A WebGroup/Virtual Host to handle /ApplicationName has not been defined" Watch " SRVE0255E: A WebGroup/Virtual Host to handle /ApplicationName has not been defined" New topic
Author

SRVE0255E: A WebGroup/Virtual Host to handle /ApplicationName has not been defined

raj khumar
Greenhorn

Joined: Dec 11, 2008
Posts: 4
I am trying to access my application running on WebSphere6.1 deployed on RAD 7.0

When I try to access the URL in browser, I get this error:-
SRVE0255E: A WebGroup/Virtual Host to handle /AppWeb has not been defined.

Nothing else is logged in the log files of the server.

What could be the problem?
[ December 11, 2008: Message edited by: raj kh ]
Paul Clapham
Bartender

Joined: Oct 14, 2005
Posts: 18109
    
    8

Raj, please check your private messages for an important administrative matter.

As far as your question is concerned, it looks like you haven't started the web application. Or you haven't configured it with the correct context root name. Or you misspelled the context root when you tried to connect to it. I'm sure there are other possibilities.
raj khumar
Greenhorn

Joined: Dec 11, 2008
Posts: 4
I have checked all these above scenarios.

When I try to publish the ear to the Server - it gives this in the startServer.log -

0000000a ManagerAdmin I TRAS0017I: The startup trace state is *=info:com.ibm.*=all.
0000000a WsServerContr 1 Executing executeUtilityOnWindows with args: c:\Program Files\IBM\SDP70\runtimes\base_v61\profiles\AppSrv08\config WW-DEVEAIH-0C7RNode04Cell WW-DEVEAIH-0C7RNode04 server1 -fromWinService \\.\pipe\w6SvcPipe_2BE58_15E34
0000000a WsServerContr 1 invokedByWindowsService has been set to true earlier
0000000a ManagerAdmin I TRAS0018I: The trace state has changed. The new trace state is *=info.
0000000a AdminTool A ADMU0128I: Starting tool with the AppSrv08 profile
0000000a AdminTool A ADMU3100I: Reading configuration for server: server1
0000000a AdminTool A ADMU3200I: Server launched. Waiting for initialization status.
0000000a AdminTool A ADMU3000I: Server server1 open for e-business; process id is 4324
00000016 WindowsServic 3 inputRec == Starting Service: WW-DEVEAIH-0C7RNode04
00000016 WindowsServic 3 inputRec ==
00000016 WindowsServic 3 inputRec == Successfully started service.
0000000a WindowsServic 1 retCode from childProcess.waitFor() is 0
0000000a WindowsServic 3 -- interrupt the thread that is collecting stdout
00000014 WindowsServic 3 readAndDisplayServiceLogFile(), caught InterruptedException
0000000a WindowsServic 3 exitCode = 0
Paul Clapham
Bartender

Joined: Oct 14, 2005
Posts: 18109
    
    8

I don't see anything in that log fragment that suggests that AppWeb was started, or that Websphere even attempted to start it.
raj khumar
Greenhorn

Joined: Dec 11, 2008
Posts: 4
When I start the server - the server gets started but it also popups a error message "Could not publish to the server."

Get a exception in C:\Program Files\IBM\SDP70\runtimes\base_v61\profiles\AppSrv08\logs\ffdc\server1_1420142_08.12.11_13.01.00_0.txt -

------Start of DE processing------ = [12/11/08 13:01:00:850 EST] , key = java.lang.IllegalArgumentException com.ibm.wsspi.runtime.component.WsComponentImpl 470
Exception = java.lang.IllegalArgumentException
Source = com.ibm.wsspi.runtime.component.WsComponentImpl
probeid = 470
Stack Dump = java.lang.IllegalArgumentException: undefined variable: MQ_INSTALL_VERSION
at com.ibm.ws.runtime.component.VariableMapImpl.referenceVariable(VariableMapImpl.java:383)
at com.ibm.ws.runtime.component.VariableMapImpl.expand(VariableMapImpl.java:316)
at com.ibm.ws.runtime.component.VariableMapImpl.substitute(VariableMapImpl.java:396)
at com.ibm.ws.runtime.component.VariableMapImpl.expand(VariableMapImpl.java:235)
at com.ibm.wsspi.runtime.component.WsComponentImpl.expandVariable(WsComponentImpl.java:468)
at com.ibm.ejs.jms.JMSRegistration.getMinimumVersion(JMSRegistration.java:464)
at com.ibm.ejs.jms.JMSRegistration.checkVersion(JMSRegistration.java:427)
at com.ibm.ejs.jms.JMSRegistration.initialize(JMSRegistration.java:176)
at com.ibm.ws.runtime.component.ContainerImpl.initializeComponent(ContainerImpl.java:1338)
at com.ibm.ws.runtime.component.ContainerImpl.initializeComponents(ContainerImpl.java:1136)
at com.ibm.ws.runtime.component.ServerImpl.initialize(ServerImpl.java:347)
at com.ibm.ws.runtime.WsServerImpl.bootServerContainer(WsServerImpl.java:177)
at com.ibm.ws.runtime.WsServerImpl.start(WsServerImpl.java:139)
at com.ibm.ws.runtime.WsServerImpl.main(WsServerImpl.java:460)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:59)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:615)
at com.ibm.wsspi.bootstrap.WSLauncher.launchMain(WSLauncher.java:183)
at com.ibm.wsspi.bootstrap.WSLauncher.main(WSLauncher.java:90)
at com.ibm.wsspi.bootstrap.WSLauncher.run(WSLauncher.java:72)
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:615)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
at org.eclipse.core.launcher.Main.run(Main.java:973)
at com.ibm.wsspi.bootstrap.WSPreLauncher.launchEclipse(WSPreLauncher.java:264)
at com.ibm.wsspi.bootstrap.WSPreLauncher.main(WSPreLauncher.java:75)

Dump of callerThis =
Object type = com.ibm.ejs.jms.JMSRegistration
com.ibm.ejs.jms.JMSRegistration@471e471e

Exception = java.lang.IllegalArgumentException
Source = com.ibm.wsspi.runtime.component.WsComponentImpl
probeid = 470
Dump of callerThis =
Object type = com.ibm.ejs.jms.JMSRegistration
WMQ_JMS_CLIENT_DETAILS = WMQ_JMS_CLIENT_DETAILS
WMQ_JMS_BUNDLE_NAME = com.ibm.ws.runtime.mqjms
tc =
defaultMessageFile = com.ibm.ejs.resources.seriousMessages
EXTENSION_NAME_DPID = DiagnosticProvider
ivDumpEnabled = false
ivResourceBundleName = com.ibm.ejs.jms.messaging
ivLogger = null
ivDiagnosticProviderID = null
anyTracingEnabled = false
ivLevel = 10
ivName = com.ibm.ejs.jms.JMSRegistration
ivDebugEnabled = false
ivEventEnabled = false
ivEntryEnabled = false
ivDetailEnabled = false
ivConfigEnabled = false
ivInfoEnabled = true
ivServiceEnabled = true
ivWarningEnabled = true
ivErrorEnabled = true
ivFatalEnabled = true
WMQ_JAVA_VAR = ${MQ_INSTALL_ROOT}
WMQ_JAVA_VERSION_VAR = ${MQ_INSTALL_VERSION}
ALL_FILES = /-
_ma88RegistrationSucceeded = false
_failureException = null
_minimumVersion = null
_currentVersion = null
_instance = this
_failureKey = null
_failureInserts = {}
class$com$ibm$ejs$jms$JMSRegistration =
serialVersionUID = 3206093459760846163
AllPermissionsPD =
codesource = null
classloader = null
principals = {}
permissions = java.security.Permissions@4be84be8
staticPermissions = true
debug = null
loopingToString = false
classNameMap =
serialVersionUID = 1978198479659022715
m = java.util.WeakHashMap@17f817f8
mutex = this.class$com$ibm$ejs$jms$JMSRegistration.classNameMap
keySet = null
entrySet = null
values = null
SYNTHETIC = 4096
ANNOTATION = 8192
ENUM = 16384
j9Version = 33686065
j9Config = 8314596479310233600
EmptyParameters = {}
name = null
state = null
propertyChangeSupport = null
inhibitMultiThreadedBehavior = false
inhibtMultiThreadedBehaviorGlobally = false
join = null
latchedAsynchronousException = null
initializers = com.ibm.ws.util.ThreadPool@ad80ad8
threadContextHelper = null
class$com$ibm$wsspi$runtime$component$WsComponentImpl =
serialVersionUID = 3206093459760846163
AllPermissionsPD = this.class$com$ibm$ejs$jms$JMSRegistration.AllPermissionsPD
classNameMap = this.class$com$ibm$ejs$jms$JMSRegistration.classNameMap
SYNTHETIC = 4096
ANNOTATION = 8192
ENUM = 16384
j9Version = 33686065
j9Config = 8314596479310233600
EmptyParameters = this.class$com$ibm$ejs$jms$JMSRegistration.EmptyParameters
class$com$ibm$ws$runtime$component$ThreadContextHelper = null
class$com$ibm$ws$runtime$service$VariableMap =
serialVersionUID = 3206093459760846163
AllPermissionsPD = this.class$com$ibm$ejs$jms$JMSRegistration.AllPermissionsPD
classNameMap = this.class$com$ibm$ejs$jms$JMSRegistration.classNameMap
SYNTHETIC = 4096
ANNOTATION = 8192
ENUM = 16384
j9Version = 33686065
j9Config = 8314596479310233600
EmptyParameters = this.class$com$ibm$ejs$jms$JMSRegistration.EmptyParameters
class$com$ibm$ws$runtime$service$Server = null
raj khumar
Greenhorn

Joined: Dec 11, 2008
Posts: 4
This is what I get in - C:\Program Files\IBM\SDP70\runtimes\base_v61\profiles\AppSrv08\logs\ffdc\server1_exception.log


Index Count Time of last Occurrence Exception SourceId ProbeId
------+------+---------------------------+--------------------------
1 1 12/11/08 13:20:31:178 EST java.lang.IllegalArgumentException com.ibm.wsspi.runtime.component.WsComponentImpl 470
------+------+---------------------------+--------------------------
+ 2 1 12/11/08 13:20:34:115 EST javax.naming.NameNotFoundException com.ibm.ws.naming.ipcos.WsnOptimizedNamingImpl.do_resolve_complete_info 1133
Quiddo Quitch
Ranch Hand

Joined: Apr 21, 2008
Posts: 38
I encountered the same. My problem was my URL was incorrect. I used port 9060 instead of 9080.

The following helped me:

WebGroup / virtual host not defined

When you have a “WebGroup / virtual host not defined” error, do the following:

Verify the virtual host configuration is correct (See “Verify the virtual host
configuration is correct” on page 26).

Verify that the URL causing the error is specified correctly (See “Verify the
URL is correct” on page 19).

If the following hasn’t been checked yet, it should be done now.
Verify the application is running (See “Verify the application is started” on
page 8)

If these actions don’t resolve your problem, see “The next step” on page 59 for
information on conducting online searches for your symptom and gathering
documentation to report the error to IBM technical support.

Link: IBM Redbook on Web container problem determination
http://www.redbooks.ibm.com/redpieces/pdfs/redp4309.pdf
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: SRVE0255E: A WebGroup/Virtual Host to handle /ApplicationName has not been defined
 
Similar Threads
Websphere issue related to the MSCM Install in Lawson
Toolkit and Local Env setup help
Application deployed in WAS 7.0.0.19 but URL Not Working
EAR deployed in websphere 6.1 but URL is not working ................
SRVE0255E: A WebGroup/Virtual Host to handle /favicon.ico has not been defined.