• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

error while invoking jndi list in jmx - console

 
krishna prasad gunasekaran
Ranch Hand
Posts: 158
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
when i tried to invoke list() method in jmx-console, jboss threw the following error



i have configured IBM jre in the jboss class path, but still it throws error. looking at the log, anything related to ant?
[ November 26, 2008: Message edited by: Ulf Dittmer ]
 
vanlalhmangaiha khiangte
Ranch Hand
Posts: 170
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
com.sun.tools.javac.Main is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK


What about your JAVA_HOME ? Is it configure ?
 
vanlalhmangaiha khiangte
Ranch Hand
Posts: 170
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you configure your JAVA_HOME ?
Through command prompt .. type set
e.g. C:\set

Tell us what JAVA_HOME is configure to ?
 
Ulf Dittmer
Rancher
Posts: 42968
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Having just edited the classpath with all those jar files, it looks quite buggy. There are lots of spaces all over the place when there shouldn't be any. I'd also remove the trailing "/" characters after many of the file names.
 
krishna prasad gunasekaran
Ranch Hand
Posts: 158
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i have set my JAVA_HOME environment variable to my jdk directory,
C:\Program Files\Java\jdk1.5.0_05
but jboss still throws the same error.

when i tried to check what my java_home is, using System.getProperty("java.home"), it displayed D:\Program Files\IBM-AppClient\java\jre, which is my jboss's installed jre path.

what's the problem? why isn't my JAVA_HOME pointing to my jdk installation directory and pointing to my jboss's installed jre path instead?
[ November 27, 2008: Message edited by: krishna prasad gunasekaran ]
 
Ulf Dittmer
Rancher
Posts: 42968
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you log out after making that change? It may not take effect until you do that.
 
krishna prasad gunasekaran
Ranch Hand
Posts: 158
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yes Ulf, i did restart my system. still java_home is jboss's installed jre path and not the one given in environment variable.
but i got the answer for my principal problem - the jsp compilation problem.
i googled and got it.
i just added tools.jar in my jboss's installed jre's path. that's it. it works.
please clear me with that java_home issue.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How are you starting JBossAS? Are you using run.bat? Is JAVA_HOME being reset within there? If you are starting it as a service, what tool are you using to do that, and how have you set JAVA_HOME within that tool's configuration settings?
 
krishna prasad gunasekaran
Ranch Hand
Posts: 158
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i don't start jboss with run.bat. i use eclipse IDE. i have configured my jboss in eclipse. i start jboss from eclipse. i haven't set JAVA_HOME in my eclipse jboss server. i have set it as environment variable.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try this. Register a JDK with Eclipse, set the JDK as the default, and try again. Also verify in the Console View that the JBossAS is using the JDK.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic