Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

start jboss-4.2.2.GA in windows service

 
Maya Pillai
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using jboss-4.2.2.GA.Can anyone tell me how to start it in windows service.
Please help me.
 
Jaikiran Pai
Marshal
Pie
Posts: 10444
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You can follow the steps mentioned here http://www.jboss.org/community/docs/DOC-10679
 
Maya Pillai
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks....I tried it,but got an error
The service name is invalid

Please help
 
Jaikiran Pai
Marshal
Pie
Posts: 10444
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please provide more details. When do you see this error? And how are you installing the service? Also please post the entire exception stacktrace
 
Maya Pillai
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I solved it,it was due to incorrect jdk home.
Now i have started jboss in windows service but the problem is,i am not able to access jboss home page while taking the page using system ip.But everything working fine when taking the page using localhost.

Please help
 
Jaikiran Pai
Marshal
Pie
Posts: 10444
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Use -b option to start JBoss. See this for details. Since you are running JBoss as a service, you need to pass the -b option by editing the service.bat file. See this for an example
 
Maya Pillai
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Everything working fine now.

Thank you so much.
 
siva Eyme
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All

I am facing a problem with jboss windows service.I am using jboss 4.2.2 GA.I have done it as a windows service.it is working fine.
The problem is ,if we are taking remote desktop using Start->Run->mstsc / console, after that I log off the remote connection,suddenly the running jboss has been stopped.I couldn't find the exat reason.If we are using only "mstsc" it is working fine eventhough the server has been logged off.
Please help me,
Thanks in advance.
 
Javid Jamae
Author
Ranch Hand
Posts: 198
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Siva, please start a new topic for this question.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic