File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Remote business methods are not required to throw RemoteException.

 
Deepak Jain
Ranch Hand
Posts: 637
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Consider the following code


Note here the remote business interface extends Remote interface and its methods do not throw RemoteException.EJB In Action book @ page 88 states that "Remote business methods are not required to throw RemoteException unless the business interface extends java.rmi.Remote interface."

The bean class business implementation did not throw RemoteException.
What is with this Remote interface and RemoteException. Everything worked fine with or without declaring the methods to throw RemoteException.
Please clarify this behavior.
 
Reza Rahman
author
Ranch Hand
Posts: 580
5
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Deepak,

This appears to be a duplicate post. As I said, it looks like you have a non-complaint implementation -- perhaps JBoss 4.2, which is not Java EE 5 certified.

Best regards,
Reza
 
Deepak Jain
Ranch Hand
Posts: 637
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am completely surprised & petrified to know that JBOSS 4.2 is not Java EE 5 certified. Petrified because i was preparing for SCBCD using JBOSS.

Does that mean i have to switch to some other Application server after being comfortable with JBoss. If yes can you please suggest a Java EE 5 certified application server.
Also where can i find a list of java ee 5 certified application servers? some url? it will be helpful for me to communicate this information across.
How bad or good is not being java ee 5 certified? And if its not certified how come its available for use ???
 
Reza Rahman
author
Ranch Hand
Posts: 580
5
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Deepak,

I don't think there is a reason to panic. From an EJB 3 perspective, JBoss 4.2 is very good functionally. Truth be told, JBoss has always been a little lax from a compliance standpoint. However, that is only one metric to a sucessful application server. Also, as I stated earlier, it is almost imposible to be 100% spec compliant. The important thing is that your code is spec compliant and therefore portable.

As to Java EE 5 certification, every major vendor is now certified, including JBoss 5, GlassFish, WebLogic 10, Geronimo and WebSphere 7.

Best regards,
Reza
 
Deepak Jain
Ranch Hand
Posts: 637
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic