wood burning stoves 2.0*
The moose likes IDEs, Version Control and other tools and the fly likes weblogic not starting properly Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "weblogic not starting properly" Watch "weblogic not starting properly" New topic
Author

weblogic not starting properly

srthul thulsri
Greenhorn

Joined: Dec 22, 2008
Posts: 1
My weblogic server starts and gets hanged after this line....

<Dec 22, 2008 12:55:59 PM IST> <Notice> <WebLogicServer> <BEA-000327> <Starting WebLogic Admin Server "mys<br /> erver" for domain "mydomain">
<Dec 22, 2008 12:56:02 PM IST> <Warning> <HTTP> <BEA-101248> <[Application: 'D:\AGSApplication\AGSApplicat<br /> ion', Module: 'iee']: Deployment descriptor "web.xml" is malformed. Check against the DTD: org.xml.sax.SAX<br /> ParseException: The content of element type "web-app" must match "(icon?,display-name?,description?,distri<br /> butable?,context-param*,filter*,filter-mapping*,listener*,servlet*,servlet-mapping*,session-config?,mime-m<br /> apping*,welcome-file-list?,error-page*,taglib*,resource-env-ref*,resource-ref*,security-constraint*,login-<br /> config?,security-role*,env-entry*,ejb-ref*,ejb-local-ref*)". (line 183, column 11).>

Please advice.....
Freddy Wong
Ranch Hand

Joined: Sep 11, 2006
Posts: 959

Check your web.xml. It's malformed as mentioned in the stacktrace.


SCJP 5.0, SCWCD 1.4, SCBCD 1.3, SCDJWS 1.4
My Blog
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: weblogic not starting properly
 
Similar Threads
problem in jsp only with bea weblogic
Problem with web.xml (WebLogic Server 8.1 SP2) ?
== Filter Problem ==
the order of XML tags in web.xml
Weblogic is crashing, VM error