aspose file tools*
The moose likes Struts and the fly likes Struts2 with JDK1.4.2_19 & Tomcat 5.0.28 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Struts2 with JDK1.4.2_19 & Tomcat 5.0.28" Watch "Struts2 with JDK1.4.2_19 & Tomcat 5.0.28" New topic
Author

Struts2 with JDK1.4.2_19 & Tomcat 5.0.28

roro star
Greenhorn

Joined: Dec 23, 2008
Posts: 1
Hi,

Has anyone had any success trying to use struts2 on java4 environment?
My server is using java 1.4.2, and they would not upgrade.

I've read the tutorial on how to use retrotranslator and I've converted the following jars:
commons-logging-j4-1.0.4.jar
freemarker-j4-2.3.8.jar
ognl-j4-2.6.11.jar

I was able to get struts2-core-j4.2.0.14.jar and xwork-j4-2.0.7.jar from struts Alternative Java 4 JARs.

When I tried to start tomcat server, I got the infamous SEVERE: ERROR filterStart.
Dec 23, 2008 12:12:09 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Dec 23, 2008 12:12:09 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 820 ms
Dec 23, 2008 12:12:09 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Dec 23, 2008 12:12:09 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.0.28
Dec 23, 2008 12:12:09 PM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
Dec 23, 2008 12:12:10 PM org.apache.catalina.core.StandardContext start
SEVERE: Error filterStart
Dec 23, 2008 12:12:10 PM org.apache.catalina.core.StandardContext start
SEVERE: Context startup failed due to previous errors
Dec 23, 2008 12:12:10 PM org.apache.catalina.core.StandardHost getDeployer
INFO: Create Host deployer for direct deployment ( non-jmx )
Dec 23, 2008 12:12:10 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Dec 23, 2008 12:12:10 PM org.apache.jk.common.ChannelSocket init
INFO: JK2: ajp13 listening on /0.0.0.0:8009
Dec 23, 2008 12:12:10 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=1/37 config=null
Dec 23, 2008 12:12:10 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 952 ms

I've configured successfully Struts 2 with JRE 1.6 & Tomcat 6.0 before, and I'm using exactly the same structure (except for web.xml, I'm using web-app version 2.4 with JDK 1.4.2, as opposed to 2.5 for JRE 1.6).
Could anyone help me?
Alejandro Galvan
Ranch Hand

Joined: Jan 02, 2008
Posts: 48
Have you tryied to change your jar files to some jdk 1.4 compatible, like struts-1.2?


SCJP 5.0<br />Preparing SCWCD
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Struts2 with JDK1.4.2_19 & Tomcat 5.0.28