wood burning stoves 2.0*
The moose likes Struts and the fly likes Struts2 dojo not working on RAD7 WS6.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Struts2 dojo not working on RAD7 WS6.1" Watch "Struts2 dojo not working on RAD7 WS6.1" New topic
Author

Struts2 dojo not working on RAD7 WS6.1

Richard Vagner
Ranch Hand

Joined: Jun 26, 2001
Posts: 107
Does anyone know if Struts2 dojo works with RAD7 Websphere server 6.1? I tried a struts2 example but it seems that dojo part is not working. Anyone has any idea or suggestions?

Thanks
Rich
Mikle Myznikov
Greenhorn

Joined: Dec 29, 2008
Posts: 5
What example do you try?
Can you post more details, f.e. error message?

Do you install Web 2.0 feature pack on WAS?
Do you use RAD 7.0 or 7.5?

Richard Vagner
Ranch Hand

Joined: Jun 26, 2001
Posts: 107
Mikle,

Thanks a lot for your reply.

1) I was following a tutorial Struts 2 + Spring 2 + JPA + AJAX at Apache Struts2 web site.


2) I am using RAD7.0 and WAS6.1. I did not install Web 2.0 feature pack on WAS before I saw you reply. I have installed it now.

3) Now I am seeing this error:


FreeMarker template error!
Expression parameters. pushId is undefined on line24, column 6 in template/ajax/a-close.ftl.
The problematic instruction:
----------
==> if parameters. pushId [on line 24, column 1 in template/ajax/a-close.ftl]


4) Isn't Struts2 embeded with Dojo? Why do we need Web2.0 feature pack?

5) I was following IBM's Redbook: Building Dynamic Ajax Applications Using WebSphere Feature Pack for Web 2.0 to install the Web 2.0 feature pack. I did not see PlantsByWebSphere example in IBM WebSphere Application Server Feature Pack by navigating File → New → Other Examples → IBM WebSphere Application Server Feature Pack for Web 2.0 samples. I am trying to find out why I am unable to see that. Can you see it? Not sure what I have missed.

Any help would be greatly appreciated.

Rich

Mikle Myznikov
Greenhorn

Joined: Dec 29, 2008
Posts: 5
what jsp page throw this error?

try to use <sx:submit /> rather than <s:submit /> (see https://issues.apache.org/struts/browse/WW-1953 for more details)

BTW, what Struts2 version do you use?
Richard Vagner
Ranch Hand

Joined: Jun 26, 2001
Posts: 107
Hi Mikle,

I reinstall the app and that error is gone. Actually I found out what the real error is. This shows in Fire fox error console:

=======================================
Error: missing ; before statement
Source File: http://localhost:9080/quickstart/struts/dojo/dojo.js
Line: 11191
Source Code:
Error 404: SRVE0190E: File not found: /struts/dojo/dojo.js
========================================

This is web.xml. I did not change anything.



Anything wrong with the config? It works in Tomcat.

Thanks so much,

Rich
Richard Vagner
Ranch Hand

Joined: Jun 26, 2001
Posts: 107
Sorry, forget this: I am using struts 2.06
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Struts2 dojo not working on RAD7 WS6.1
 
Similar Threads
Showing Hiding <s:div> tag in Struts2
ajax and struts2
Struts2 Validation
Struts2 Jquery vs Struts2 Dojo
Struts1 and Struts2