File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Web Services and the fly likes AXIS1.4- webservice cleint Issue Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "AXIS1.4- webservice cleint Issue" Watch "AXIS1.4- webservice cleint Issue" New topic
Author

AXIS1.4- webservice cleint Issue

ashirvad jain
Ranch Hand

Joined: Nov 09, 2006
Posts: 50
hello Friends
I am using AXIS1.4 fow webservice cleint.
I have generated stubs using WSDL2Java of axis.
It has generated classes and other additional class like:-

ServiceLocator
Port
PortStub
Service

But when i am using ,
Service service=new ServiceLocator();
PortStub stub=PortStub(endPoint,service);

endpoint-wsdl URl;

its giving me java.lang.NullPointerException .
PLease guide me to resolve my issue.

I can't move to axis upgarde versions.

I tried lot googling but still stuck. PLEASE PROVIDE any code snippet if possible.

thank in advance.
Peer Reynders
Bartender

Joined: Aug 19, 2005
Posts: 2922
    
    5
Axis 1.x client code tends to follow the same pattern:

service := serviceLocator
port := service.getBindingStub( differentUrl )
response := port.webMethod(request)




See also Creating Web Services with Apache Axis (1.x)

The above code comes from an example discussed in Empty Namespace in SOAP (Axis 1.4).
ashirvad jain
Ranch Hand

Joined: Nov 09, 2006
Posts: 50
Thanks for your kind reply.

I some how able to solve that issue.
Actually i was troubling to get web cleint . I referred lot of document and rest info.
Actually i was facing some configuration issue with eclipse.so was not able to solve that.
But now its solved somehow

But i really appriciate your reply.

Do best and keep posting..

Thank you.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: AXIS1.4- webservice cleint Issue
 
Similar Threads
How to set Username and pwd in SOAP header using Axis 1.4
ContractFilter mismatch at the EndpointDispatcher
Issue in getting expected response from webservice
about apache axis
Dynamic Invocation Class from Client