wood burning stoves 2.0*
The moose likes BEA/Weblogic and the fly likes Trying to deploy application in Weblogic 10.0 !!!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Trying to deploy application in Weblogic 10.0 !!!!" Watch "Trying to deploy application in Weblogic 10.0 !!!!" New topic
Author

Trying to deploy application in Weblogic 10.0 !!!!

Steve Adam
Ranch Hand

Joined: Jan 07, 2009
Posts: 40
Hello everyone,
I have been trying to deploy my application in Weblogic 10.0.
But when I try to do so using console, I get DeploymentException & ZipException

Zip Exception states - unable to open zip file.

What exactly is this? My application doesnt have any zip file.
It has one '.jar file of the EJBs' and 'WEB folders' and 'xml files


Its not what you do, its how well you do it.
Steve Adam
Ranch Hand

Joined: Jan 07, 2009
Posts: 40
This is the actual exception:


####<Jan 19, 2009 10:23:56 PM CST> <Error> <Deployer> <DMZ-SYN-WKS90> <AdminServer> <[STANDBY] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1232425436415> <BEA-149265> <Failure occurred in the execution of deployment request with ID '1232425435650' for task '0'. Error is: 'weblogic.management.DeploymentException: '
weblogic.management.DeploymentException:
at weblogic.application.internal.flow.LibraryDirectoryFlow.prepare(LibraryDirectoryFlow.java:50)
at weblogic.application.internal.BaseDeployment$1.next(BaseDeployment.java:615)
at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:26)
at weblogic.application.internal.BaseDeployment.prepare(BaseDeployment.java:191)
at weblogic.application.internal.DeploymentStateChecker.prepare(DeploymentStateChecker.java:147)
at weblogic.deploy.internal.targetserver.AppContainerInvoker.prepare(AppContainerInvoker.java:61)
at weblogic.deploy.internal.targetserver.operations.ActivateOperation.createAndPrepareContainer(ActivateOperation.java:189)
at weblogic.deploy.internal.targetserver.operations.ActivateOperation.doPrepare(ActivateOperation.java:87)
at weblogic.deploy.internal.targetserver.operations.AbstractOperation.prepare(AbstractOperation.java:21
at weblogic.deploy.internal.targetserver.DeploymentManager.handleDeploymentPrepare(DeploymentManager.java:719)
at weblogic.deploy.internal.targetserver.DeploymentManager.prepareDeploymentList(DeploymentManager.java:1186)
at weblogic.deploy.internal.targetserver.DeploymentManager.handlePrepare(DeploymentManager.java:248)
at weblogic.deploy.internal.targetserver.DeploymentServiceDispatcher.prepare(DeploymentServiceDispatcher.java:157)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer.doPrepareCallback(DeploymentReceiverCallbackDeliverer.java:157)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer.access$000(DeploymentReceiverCallbackDeliverer.java:12)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer$1.run(DeploymentReceiverCallbackDeliverer.java:45)
at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:464)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:200)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:172)
java.util.zip.ZipException: error in opening zip file
at java.util.zip.ZipFile.open(Native Method)
at java.util.zip.ZipFile.><init>(ZipFile.java:203)
at java.util.zip.ZipFile.<init>(ZipFile.java:234)
at weblogic.utils.classloaders.ZipClassFinder.<init>(ZipClassFinder.java:23)
at weblogic.utils.classloaders.JarClassFinder.<init>(JarClassFinder.java:35)
at weblogic.utils.classloaders.JarClassFinder.<init>(JarClassFinder.java:25)
at weblogic.utils.classloaders.JarClassFinder.<init>(JarClassFinder.java:21)
at weblogic.application.internal.flow.LibraryDirectoryFlow.prepare(LibraryDirectoryFlow.java:43)
at weblogic.application.internal.BaseDeployment$1.next(BaseDeployment.java:615)
at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:26)
at weblogic.application.internal.BaseDeployment.prepare(BaseDeployment.java:191)
at weblogic.application.internal.DeploymentStateChecker.prepare(DeploymentStateChecker.java:147)
at weblogic.deploy.internal.targetserver.AppContainerInvoker.prepare(AppContainerInvoker.java:61)
at weblogic.deploy.internal.targetserver.operations.ActivateOperation.createAndPrepareContainer(ActivateOperation.java:189)
at weblogic.deploy.internal.targetserver.operations.ActivateOperation.doPrepare(ActivateOperation.java:87)
at weblogic.deploy.internal.targetserver.operations.AbstractOperation.prepare(AbstractOperation.java:217)
at weblogic.deploy.internal.targetserver.DeploymentManager.handleDeploymentPrepare(DeploymentManager.java:719)
at weblogic.deploy.internal.targetserver.DeploymentManager.prepareDeploymentList(DeploymentManager.java:1186)
at weblogic.deploy.internal.targetserver.DeploymentManager.handlePrepare(DeploymentManager.java:248)
at weblogic.deploy.internal.targetserver.DeploymentServiceDispatcher.prepare(DeploymentServiceDispatcher.java:157)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer.doPrepareCallback(DeploymentReceiverCallbackDeliverer.java:157)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer.access$000(DeploymentReceiverCallbackDeliverer.java:12)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer$1.run(DeploymentReceiverCallbackDeliverer.java:45)
at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:464)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:200)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:172)
>
Mathias Schneider
Greenhorn

Joined: Oct 29, 2008
Posts: 5
I have the same problem with Weblogic 10.3



How to fix it?
Mathias Schneider
Greenhorn

Joined: Oct 29, 2008
Posts: 5
I fixed it:

I just renamed the EAR file. Now the Hot-Deployment works again.

But the original EAR file name still will not work except for manual deployment. I think there is a problem with the Server Adapter for Eclipse Galileo SR2, because setting up a new workspace does not solve this problem.
Rajendra Nandam
Greenhorn

Joined: Oct 26, 2009
Posts: 8
Hi,

Want to know how you are deploying the application and also the O.S ( Windows/Unix Family).

The similar kind of issue occured to me ,because the issue here i faced is the file is not properly copied/Corrupted while copying from one location to another location.

Please check the file size of your application once. Thanks in Advance!!!

Thanks
Nandam
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Trying to deploy application in Weblogic 10.0 !!!!