• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Getting error while starting weblogic 10.3 server from start\programs\oraweblogic\....

 
bhushan kumarsel
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi I created a sample domain through weblogic configutration wizard.
Started the admin server for this domain(through user_prijects).Then stopped it.

Then i tried to start weblogic server (start\programs\oraweblogic\weblogic\weblogicserver icon)
But earolier it was starting well.

Now after creation of the domain. I am getting following error .

***************************************************
* To start WebLogic Server, use a username and *
* password assigned to an admin-level user. For *
* server administration, use the WebLogic Server *
* console at http:\\hostname:port\console *
***************************************************
starting weblogic with Java version:
java version "1.6.0_05"
Java(TM) SE Runtime Environment (build 1.6.0_05-b13)
BEA JRockit(R) (build R27.6.0-50_o-100423-1.6.0_05-20080626-2105-windows-ia32, compiled mode)
Starting WLS with line:
C:\Bea10.3\JROCKI~1\bin\java -jrockit -Xms256m -Xmx512m -Dootb.examples.url.name=/index.jsp -Xverify:none -da -Dplatform.home=C:\Bea10.3\WLSERV~1.3 -Dwls.home=C:\Bea10.3\WLSERV~1.3\server -Dwe
<Jan 20, 2009 7:25:01 PM IST> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with BEA JRockit(R) Version R27.6.0-50_o-100423-1.6.0_05-20080626-2105-windows-ia32 from BEA Systems,
><Jan 20, 2009 7:25:02 PM IST> <Critical> <WebLogicServer> <BEA-000362> <Server failed. Reason:

There are 1 nested errors:

weblogic.management.ManagementException: Unable to obtain lock on C:\Bea10.3\wlserver_10.3\samples\domains\wl_server\servers\examplesServer\tmp\examplesServer.lok. Server may already be running
at weblogic.management.internal.ServerLocks.getServerLock(ServerLocks.java:159)
at weblogic.management.internal.ServerLocks.getServerLock(ServerLocks.java:58)
at weblogic.management.internal.DomainDirectoryService.start(DomainDirectoryService.java:73)
at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesManager.java:459)
at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServicesManager.java:164)
at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:711)
at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:482)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:440)
at weblogic.Server.main(Server.java:67)

>
<Jan 20, 2009 7:25:02 PM IST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED>
<Jan 20, 2009 7:25:02 PM IST> <Error> <WebLogicServer> <BEA-000383>
<Jan 20, 2009 7:25:02 PM IST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>
Stopping PointBase server...
PointBase server stopped.

C:\Bea10.3\wlserver_10.3\samples\domains\wl_server>
 
Eric Pascarello
author
Rancher
Posts: 15385
6
posted 7 years ago
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Moving to the correct forum

Eric
 
Renjan Thomas
Ranch Hand
Posts: 49
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

This exception is thrown when already a WLS process is running...try to kill all the WLS process running and restart the instance again.If it is a windows machine..use the process tab in task manager to see the java process running..and if it is unix machine please do a grep command to check the weblogic java process and kill it.
 
shimon ohayon
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi
i try to typr those commands:
ps -ef | grep "weblogic" Or ps -ef | grep "java" -> ther is no WLS instance
but i stiil got this error:
weblogic.management.ManagementException: Unable to obtain lock on /asmsuser06/amss/amss/abma51/ASMS/JEE/orchDomain__abma51/WLS/orchDomain__abma51ASMS/JEE/servers/orchServer__abma51/tmp/orchServer__abma51.lok. Server may already be running
at weblogic.management.internal.ServerLocks.getServerLock(ServerLocks.java:159)
at weblogic.management.internal.ServerLocks.getServerLock(ServerLocks.java:58)
at weblogic.management.internal.DomainDirectoryService.start(DomainDirectoryService.java:73)
at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesManager.java:459)
at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServicesManager.java:164)
at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:711)
at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:482)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:440)
at weblogic.Server.main(Server.java:67)

please assit,
]Shimon
 
Renjan Thomas
Ranch Hand
Posts: 49
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Then if you are so sure that your server is not running...try this :-

Delete the file AdminServer.lok

Go to
"your domain"\servers\AdminServer\tmp\

Delete the file AdminServer.lok.Then try starting the server.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic