aspose file tools*
The moose likes JBoss/WildFly and the fly likes overriding container settings for indivisual bean Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "overriding container settings for indivisual bean" Watch "overriding container settings for indivisual bean" New topic
Author

overriding container settings for indivisual bean

Vikky Bhat
Greenhorn

Joined: Oct 23, 2008
Posts: 20
hi folks,
we are using jboss 4.2GA for our project which uses stateful beans..and jboss is using default container settings..now the problem is for a perticular bean i need to override the container defaults. i.e its inactive time should be 4 hrs instead 10 min....please help me out..


SCJP, SCWCD, WIPO-IP
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5772
    
    7

EJB3 or EJB2.x?


JBoss In Action
Vikky Bhat
Greenhorn

Joined: Oct 23, 2008
Posts: 20
Thank you Peter for your quick reply....
we are using EJB2.x. for a bean we need to increase the bean age inside the container. other container details are as follows commit option B with BMT and pessimistic locking. this is my jboss.xml for bean

<jboss>
<container-configurations>
<container-configuration>
<container-name>Standard BMP EntityBean</container-name>
<commit-option>B</commit-option>

</container-configuration>
</container-configurations>
<enterprise-beans>

<session>
<ejb-name>KnowledgeBankSessionEJB</ejb-name>
<jndi-name>KnowledgeBankSessionJNDI</jndi-name>
</session>

<entity>
<ejb-name>KnowledgeBankEntityEJB</ejb-name>
<jndi-name>KnowledgeBankEntityJNDI</jndi-name>
</entity>


</enterprise-beans>
<resource-managers></resource-managers>
</jboss>


where exactly can override the container defaults ?...i cant do hit and try because application is going to production phase shortly...thanks in advance
Vikky Bhat
Greenhorn

Joined: Oct 23, 2008
Posts: 20
Vikky Bhat wrote:hi folks,
we are using jboss 4.2GA for our project which uses stateful beans..and jboss is using default container settings..now the problem is for a perticular bean i need to override the container defaults. i.e its inactive time should be 4 hrs instead 10 min....please help me out..
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5772
    
    7

Play around with the overager-period values found in server/xxx/conf/standardjboss.xml. There are several EJB caches defined in that file, it might take some experimenting to find out which one contains your bean.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: overriding container settings for indivisual bean
 
Similar Threads
Preventing Passivation of statefull bean
developing my first struts application. So need some help
stateless session bean
Maximum No.of connections in Jboss
Transation type default