• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

EJB 3.0 & 2.0 compatibility

 
skumar nand
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We are planning to develop a EJB3.0 application on WebLogic 10.3 server.
We suppose to use some jar files (e.g xyz.jar) which used EJB2.0 for their development.
In this case will my application(EJB 3.0) work with the xyz.jar(EJB2.0)?
Or we need to get the EJB3.0 version of xyz.jar to use with our application?

Thanks in Advance,
 
Joe Harry
Ranch Hand
Posts: 10112
3
Eclipse IDE Mac PPC Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Your question seems not to be clear. Did you mean the jar files for the EJB API? If is the EJB API jar, then you need to have the latest specification which is EJB 3.0.
 
Joe Harry
Ranch Hand
Posts: 10112
3
Eclipse IDE Mac PPC Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
As per the EJB 3.0 specification, the application servers implementing the EJB 3.0 spec should be backward compatible.
 
Reza Rahman
author
Ranch Hand
Posts: 580
5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Skumar,

FYI, there is a chapter in EJB 3 in Action dedicated to EJB 2.x and EJB 3.0 compatibility, interoperability and migration issues.

As Jothi stated, WebLogic 10 will fully support the co-existance of EJB 2 and EJB 3, so you can undertake the migration in a phased manner.

Cheers,
Reza
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic