File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes IDEs, Version Control and other tools and the fly likes getting Project facet Java version 6.0 is not supported. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "getting Project facet Java version 6.0 is not supported." Watch "getting Project facet Java version 6.0 is not supported." New topic
Author

getting Project facet Java version 6.0 is not supported.

vipin jain
Ranch Hand

Joined: Aug 24, 2008
Posts: 122
hi i am getting Project facet Java version 6.0 is not supported error.
i have done all require change to set jdk1.5 but still i am getting same problem.
can any one tell me perfect solution of this problem....


Best Regards,<br />Vipin<br />MCA, SCJP5, SCWCD in progress
vipin jain
Ranch Hand

Joined: Aug 24, 2008
Posts: 122
hi i got the solution of this problem....
it's require to setting
properties of project->
Project Facets->
click on modify profile button->open new window select drop down java new version
|
click on finish [down]

it's reference for other people
Campbell Ritchie
Sheriff

Joined: Oct 13, 2005
Posts: 37907
    
  22
Is that on a particular IDE? If so, please tell us which IDE: and it might have been better to post on the IDEs forum
Charan kumar sarvepalli
Ranch Hand

Joined: Dec 14, 2008
Posts: 40
Thanks for the post i am also getting the same error in Eclipse Galielo it is solved. after i changed in project -> properties -> project factes to 5.0


-- Charan
Tanmoy Palodhi
Greenhorn

Joined: May 21, 2007
Posts: 13
This has worked for me in Eclipse3.4.2 (Ganymede):
Goto project properties -> Select Project Facets -> Check the Java version, if it is other than java 5.0 then selected 5.0 from the drop down.

Thanks
Tanmoy
shu jane
Greenhorn

Joined: Jan 04, 2011
Posts: 1
I am useing MyEclipse8.6/jdk1.6,while new web projet it will alert 'Compiler compliance leve of project XX should be 5.0,your current workspace default is 6.0.'
How do I put j2ee6 join MyEclipse8.6 ?
thanks..
hiyat kemu
Greenhorn

Joined: Jan 09, 2014
Posts: 1
finally my problem get solved for project facet error

you can also find this link valuable for your error removed

click here to reach page

they are providing picture demonstration too with explanation for eclipse

 
It is sorta covered in the JavaRanch Style Guide.
 
subject: getting Project facet Java version 6.0 is not supported.
 
Similar Threads
Problem with Facets in Eclipse for dynamic web project
struts2 newbie: (1) how to validate without xml & (2) how to have a dispatchAction?
Project facet Java 6.0 is not supported by target runtime WebSphere Application Server v6.1.
EL Syntax error
Not supported version