File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes Web Application Manager authorization problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Web Application Manager authorization problem" Watch "Web Application Manager authorization problem" New topic
Author

Web Application Manager authorization problem

Max Qua
Greenhorn

Joined: Sep 27, 2008
Posts: 20
Hi,
I tried to use the Web Application Manager for managing the application under localhost.
I had no problem using it, accessing as admin with manager role.
However when I tried to manage the applications under another virtual host I got problems in getting authorized.
Simply entering the admin and the password, the login mask appears again asking me the login an password. I cannot access, no error messages, just a new login mask.
I use tomcat 6 with IIS 6, all applications are working correctly. If I disable the security in manager.xml I can use the web Application Manager but of course it is not secure.
Please could you help? Is there a way to trace what is happening?
Tell me what info it is necessary to post for you to understand the cause of this problem.

Many thanks
udaykumar maddigatla
Ranch Hand

Joined: Feb 03, 2009
Posts: 69
Hey what your typing in the another system in order to access the tomcat which is in your system

is it http://localhost:8080/

Make this correction in the virtual host :You have to type your system ip address instead of localhost.

SCJP 5.0(84%), SCWCD 5.0(97%), SCDJWS 5.0(98%)
Max Qua
Greenhorn

Joined: Sep 27, 2008
Posts: 20
Hi,
I'm sorry I don't think I understood what I have to correct according to your proposal.
I try to explain better:
using http://localhost:8080/manager/html I am able to login as a manager tomcat user with no problem

using http://www.mydomain.com/manager/html I got a mask asking to login but this time after entering name and password another mask pops up

The virtual host www.mydomain.com is mapped on a dir and the web site is under C:\www.mydomain.com\webapps\ROOT while the manager directory has been copied from tomcat webapps in C:\www.mydomain.com\webapps\

Please help

/Max
Jeena Jeen
Ranch Hand

Joined: Feb 11, 2009
Posts: 47
Also have a similar problem. I have a web application and i am trying to access my application it asks for user name and password again and again without any warning. I have window Vista. I read some other forums also. People have troubles with Vista. I tried to run tomcat as admin also(as mentioned on lot of forums) but thats not a much of help. I have updated "tomcat-users.xml" with user name and password.
Does anyone has idea how to solve this issue?
Max Qua
Greenhorn

Joined: Sep 27, 2008
Posts: 20
Is there any expert in this forum who can help on this topic?

Thanks

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Web Application Manager authorization problem
 
Similar Threads
tomcat installation problem
Sun Application Server Login
What is default user/pass for weblogic 8.1 admin consle?
Unable to login to manager GUI
Unable to access admin console of tomcat