*
The moose likes BEA/Weblogic and the fly likes question about weblogic Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "question about weblogic" Watch "question about weblogic" New topic
Author

question about weblogic

lynn fann
Ranch Hand

Joined: Oct 15, 2006
Posts: 115
i have the following code in web.xml:
<servlet>
<servlet-name>MainServlet</servlet-name>
<display-name>MainServlet</display-name>
<servlet-class>com.sun.j2ee.blueprints.waf.controller.web.MainServlet</servlet-class>
<init-param>
<param-name>default_locale</param-name>
<param-value>en_US</param-value>
</init-param>
</servlet>

<servlet-mapping>
<servlet-name>MainServlet</servlet-name>
<url-pattern>/bb*</url-pattern>
</servlet-mapping>

Currently the url-mapping for the actionClasses, is something like this "bbpage1.jsp", "bbpage2.jsp".

The above setting works in oracle.. but not in weblogic. Weblogic doesnt recognise the url-pattern. I need to set "/bb*" to "*.do", for it works, as well as to change the url-mapping to ".do" extension.

But is there a way to set it so that weblogic recognise the url-pattern as "/bb*" because i do not want to change the extension?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: question about weblogic
 
Similar Threads
Getting servlet to work with TOMCAT4.1.18
JSP container?
blank index.jsp on Tomcat 5.5.9
STRUTS + WEBLOGIC 8.1
web.xml causes 404 error