aspose file tools*
The moose likes Websphere and the fly likes Installing WebSphere Application Server 6.1 - Can't find suitable JVM Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Installing WebSphere Application Server 6.1 - Can Watch "Installing WebSphere Application Server 6.1 - Can New topic
Author

Installing WebSphere Application Server 6.1 - Can't find suitable JVM

Bill Lee
Greenhorn

Joined: Feb 02, 2007
Posts: 20
When I attempt to run the install.exe on Websphere Application Server 6.1, I get the following message.


A suitable JVM could not be found. Please run the program again using the option -is:javahome <JAVA HOME DIR>

I have proceeded to run the following commands

install.exe -is:javahome D:\Projects\jdk1.5.0_12

install.exe -is:javahome D:\Projects\jre1.5.0_12


In my environment variable, I have the following set in System Variable

JAVA_HOME D:\Projects\jdk1.5.0_12

At this point, I am not sure what other things I should try.

Thanks in advance.
Ramakanta Sahoo
Ranch Hand

Joined: Aug 23, 2008
Posts: 254

Check the JDK version bundled with your Application Server Software.
Its always better to use the IBM's provided JDK.

May be you need to remove the your own JDK from the PATH.


Thanks,
-Ricky


Regards, Ricky
Oracle Weblogic 10g Certified Expert TechPaste.Com
Greg Burdett
Greenhorn

Joined: Jan 23, 2003
Posts: 4
I had the same issue, removed my JAVA_HOME and PATH entries, but that did not help in my case. However, I then realized that I had installed the latest version of the Websphere Update Installer, and I checked the Java version on it - it was Java 6, newer than the Java 5 that came bundled with Webshere, and I had overwritten the Websphere install package's JDK directory in the process. I simply unpacked the Websphere package to restore the original JDK directory containing Java 5, and the install worked fine.

Greg Burdett
kona krishnakumar
Ranch Hand

Joined: Dec 03, 2011
Posts: 32
Hi All,

Iam also getting the same issue.

I had downloaded Websphere ND v7. IBM's JDK will come bundled along with the WAS software or we have to download seperately.
Could any one please clarify on above.

Greg Burdett,

I uninstalled existed JDK and tried to install Websphere again getting the same error again. As I mentioned above, Do we have to download IBM's JDK seperately ?

Thanks in Advance
Krishna
Greg Burdett
Greenhorn

Joined: Jan 23, 2003
Posts: 4
A JVM has traditionally been packaged with Websphere, so I would assume that is still the case in v7. You should not have to download one separately - unless you want to, of course. It usually does not create problems, but it did in this case, because the update installer was expecting Java 6, and Websphere came with Java 5.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Installing WebSphere Application Server 6.1 - Can't find suitable JVM