Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Can't get past BASIC authentication

 
Paul Kemp
Ranch Hand
Posts: 35
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My tomcat-users.xml file looks like this:



And my DD:



My index.html page has this link on it, to private/private-page.jsp.

I click on the link and I get the ugly grey box requiring me to enter a user name and password for BASIC authentication.
All is good.
I type in username = paul, password=kemp, but the grey box won’t let me through: the grey box just keeps on coming back.

What am I doing wrong?

Thanks
 
Paul Kemp
Ranch Hand
Posts: 35
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I fixed this problem.

In case anyone else experiences this, the issue was not with the code.

I am using the Eclipse IDE, and starting and stopping the server with a Tomcat plugin. Whilst developing, I encountered the behaviour described above.

However, when I exported the project as a WAR file to the Tomcat directory, and started the Tomcat server from its bin folder, the program worked correctly.
 
Tuna Töre
Ranch Hand
Posts: 220
Eclipse IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Wooww Paul ...Did you solve this problem.
I had the same issue one month ago when I was studying security concepts... And I didn't find a solution for that(grey box never closed)...
I am now going to try your solution..
Thanks...

 
Tuna Töre
Ranch Hand
Posts: 220
Eclipse IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes this works for me too..
Moreover friends do not forget to copy your war file under webapps folder under apache tomcat... because eclipse put its project in a different folder like
wtp...
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic