This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Websphere and the fly likes Problem with RAD 7 and WebSphere 6 / 6.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Problem with RAD 7 and WebSphere 6 / 6.1" Watch "Problem with RAD 7 and WebSphere 6 / 6.1" New topic
Author

Problem with RAD 7 and WebSphere 6 / 6.1

pepe lotas
Greenhorn

Joined: Feb 20, 2009
Posts: 10
Hi!!

I'm new to RAD (but I know some about eclipse), and I'm starting with RAD 7 + WebSphere 6.

In RAD, in the workspace, I create a profile, then I create a server. Finally I create a dinamic web project adding the project to an EAR, with RAD's wizard.
In that project I just create a JSP, with a "Hello World" text.
And I add the EAR to the server.

Then, when I am going to start or stop the server, I have problems. I am serving from localhost. If in the server conectivity I choose "SOAP", the server will start and stop ok every time from RAD, but not from command line typing startserver, stopserver or serverstatus. It does not work too well.
But if I set the server conectivity to "RMI", it will sometimes start the server the very first time I try, but then it does not start again, it hangs, and I have to exit RAD, and sometimes JAVA or JAVAW process remains and I have to do ctrl+shift+esc to kill the process manually.
Also some ports used by websphere remain listening when they should not

I can serve and see the JSP in iexplore as well as in firefox once the server is up.

But a friend of mine, having the same software as I, just can't serve the page, he gets a server error saying that the page cannot be found :-S
He stops the server (being "SOAP" or "RMI") and the server says (stopped) but, the process will remain, and if he tries again, he gets the same error, too weird.
He installed websphere 5, and he gets no problems with that one, but we want to use versiĆ³n 6 or 6.1, and with both of them we get problems.

Our RAD installation was made in spanish languaje, could that deal with these problems?

Do you know about some issues with these? How could we solve it? We are thinking on getting RAD 7.5

We also have the documentation of "Rational Application Developer V7 Programming guide" a 1390 pages PDF, we follow instructions there but we have these problems.

Help!!!

Thanks in advance!!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem with RAD 7 and WebSphere 6 / 6.1
 
Similar Threads
WP 6.1 Test Environment unavailable in RAD 7.5.0 iFix001
RAD 7.0 Version -- Please Help
RAD 7.5 NameAlreadyBoundException
How to remove deleted project from server profile
Websphere 6.1 - Unable to recogize jar's in EAR