my dog learned polymorphism*
The moose likes Other Languages and the fly likes How to install Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Languages » Other Languages
Bookmark "How to install "Fast Debugger" using Netbeans as IDE for Ruby?" Watch "How to install "Fast Debugger" using Netbeans as IDE for Ruby?" New topic
Author

How to install "Fast Debugger" using Netbeans as IDE for Ruby?

Rogerio Kioshi
Ranch Hand

Joined: Apr 12, 2005
Posts: 689
Hi,

I'm using Netbeans 6.0 as IDE for Ruby coding.
When I try to debug some code, the following warning is shown:

For debugging applications under native Ruby interpreter, the Fast Debugger, which is available
as a gem, may be used. Do you want to install it now or continue with the dafault(slow) debugger?


I choose "Install" and the following message is shown:

Screen "Gem Installation"
ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)
Bad file descriptor - connect(2)(Errno::EBADF)



I also tried to install by command line, but the same error happens:

1. C:\ruby>gem install ruby-debug-ide
2. ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)
3. Bad file descriptor - connect(2)(Errno::EBADF)
4.
5. C:\ruby>


SCEA 5 (part 1), SCBCD, SCWCD, SCJP, CLP, CLS
Assaf Arkin
Author
Greenhorn

Joined: Feb 09, 2009
Posts: 16
Are you using a proxy server? Try using the option --http-proxy or setting the HTTP_PROXY environment variable.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: How to install "Fast Debugger" using Netbeans as IDE for Ruby?
 
Similar Threads
JBoss Clustering
ERROR 1016 (HY000): Can't open file: 'TABLE_NAME.InnoDB' (errno: 1) - MySQL
openoffice 3.1 Defective java runtime error
Installing Rails Issue
Fed Up Installing Rails.... How Do I Get Rid Of The Dependencies?