Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Eclipse won't start up after update

 
Joe Gliniecki
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I was running Eclipse WTP 3.0.3 fine for months. Today I decided to update to 3.0.4. The update went fine and it asked me to restart as usual. However eclipse will now no longer start since the update.

The small screen that usually shows Eclipse starting up is displayed for only a split second and then goes away. Also, the log file at <workspace_dir>/.metadata/.log is not updated from the attempted start. Not sure if there are any other log files to look at.

The last entry in the log it this:


with many more of the "requiredCapability" lines.

This happened to me last fall also, and I then just re-installed Eclipse from scratch (since I couldn't start Eclipse to revert to the old configuration), but thought I'd now try and see if there is a solution, or maybe a bug that the community could be made aware of.

Thanks,
Joe
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maybe I should not even suggest this, but here goes. Every time I have run into something like this, the only solution I have found is to re-install Eclipse. I have lost track of the number of times I have reinstalled Eclipse because of an upgrade gone bad. But them on my desktop I have am currently running at least 4 different Eclipse installations, each with different sets of plugins, so I don't find installing Eclipse all that onerous.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic