This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Sockets and Internet Protocols and the fly likes NIO Socket weirdnes in Solaris 2.10 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » Sockets and Internet Protocols
Bookmark "NIO Socket weirdnes in Solaris 2.10" Watch "NIO Socket weirdnes in Solaris 2.10" New topic
Author

NIO Socket weirdnes in Solaris 2.10

luri ron
Ranch Hand

Joined: Dec 11, 2008
Posts: 87
I tried a client/server NIO server program, and saw some weird behavior.

If i run the client and server on the same Window desktop machine. the work with each other. client conect to the server, query the instrument and get the list of instruments back.

however, if i ran client and server on the Solaris 2.10 box, the NioClient doesn't get anything back from the MockServer. the even more ineresting thing is that, if i run the server on a different solaris 2.10 machine, everything then starts to work.

can sometone sheds some lights? here are the codes.

the NioClient.java


the MockServer.java
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: NIO Socket weirdnes in Solaris 2.10
 
Similar Threads
ServerSocketChannel.accept() seems to create a random port to send data to?
java.net.BindException: Address already in use
does a nio socket buffer data internally too?
socket programming : connect server to client
non blocking socket