aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Problems w/ Eclipse RCP Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Problems w/ Eclipse RCP" Watch "Problems w/ Eclipse RCP" New topic
Author

Problems w/ Eclipse RCP

John Archuletta
Greenhorn

Joined: Mar 13, 2009
Posts: 1
Hello everyone! Nice to meet you all.

I'm trying to get up and running with the Eclipse RCP but I'm running into problem after problem after problem...

I just bought the book "Eclipse Rich Client Platform" from Addison Wesley and I just cannot seem to get the book sample projects to run. Here's the error log I get when trying to run them:

!SESSION 2009-03-13 17:30:53.828 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_12
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product org.eclipsercp.hyperbola.product
Command-line arguments: -product org.eclipsercp.hyperbola.product -data C:\My Projects\Eclipse Ganymede/../runtime-hyperbola.product -dev file:C:/My Projects/Eclipse Ganymede/.metadata/.plugins/org.eclipse.pde.core/hyperbola.product/dev.properties -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.core.runtime 4 0 2009-03-13 17:30:54.078
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)"
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:355)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1074)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:616)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:299)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:489)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:211)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:321)

!ENTRY org.eclipse.update.configurator 4 0 2009-03-13 17:30:54.078
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)"
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:355)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1074)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:616)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:299)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:489)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:211)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:321)

!ENTRY org.eclipse.osgi 4 0 2009-03-13 17:30:54.078
!MESSAGE Bundle initial@reference:file:../Eclipse SDK/plugins/org.eclipse.core.runtime_3.4.0.v20080512.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2009-03-13 17:30:54.078
!MESSAGE Bundle initial@reference:file:../Eclipse SDK/plugins/org.eclipse.update.configurator_3.2.201.R34x_v20080819.jar/ was not resolved.

!ENTRY org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE Bundle initial@reference:file:../Eclipse SDK/plugins/org.eclipse.update.configurator_3.2.201.R34x_v20080819.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE Bundle initial@reference:file:../Eclipse SDK/plugins/org.eclipse.core.runtime_3.4.0.v20080512.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).

!ENTRY org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE Bundle initial@reference:file:../Eclipse SDK/plugins/org.eclipse.update.configurator_3.2.201.R34x_v20080819.jar/ [2] was not resolved.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE Bundle initial@reference:file:../Eclipse SDK/plugins/org.eclipse.core.runtime_3.4.0.v20080512.jar/ [3] was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing imported package org.eclipse.core.internal.runtime.auth_0.0.0.

!ENTRY org.eclipse.osgi 4 0 2009-03-13 17:30:54.078
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
at org.eclipse.equinox.launcher.Main.main(Main.java:1212)

!ENTRY org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE Bundle initial@reference:file:../Eclipse SDK/plugins/org.eclipse.update.configurator_3.2.201.R34x_v20080819.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE Bundle initial@reference:file:../Eclipse SDK/plugins/org.eclipse.core.runtime_3.4.0.v20080512.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).

!ENTRY org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE Bundle initial@reference:file:../Eclipse SDK/plugins/org.eclipse.update.configurator_3.2.201.R34x_v20080819.jar/ [2] was not resolved.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-03-13 17:30:54.078
!MESSAGE Bundle initial@reference:file:../Eclipse SDK/plugins/org.eclipse.core.runtime_3.4.0.v20080512.jar/ [3] was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2009-03-13 17:30:54.078
!MESSAGE Missing imported package org.eclipse.core.internal.runtime.auth_0.0.0.


If anyone can help me I would REALLY appreciate it. I think I might be in over my head...
Lars Olson
Greenhorn

Joined: Apr 23, 2009
Posts: 2
Hi fellow RCP newbie!
I realize this post is rather old, but I might as well share my findings with the community

I am myself aRCP newbie and so I am well aware of your problem!

The issue you are facing is the following:
The book you have bought, published in 2005 was made to work with the Eclipse 3.1 codebase. As we are now in 2009, Eclispe is in version 3.4 and a lot has changed since 3.1 This is why the book examples do not work out of the box.

I also tried to install the book's plugin in eclipse 3.4 and tried to run them. It's quite a neat feature, if only it had worked


So what is the solution to your problem?
First of all, you could go into the eclipse archives and download a working copy of Eclipse 3.1 (RCP edition) . I have not tried it but it should work. I do not think this is the proper way to do it though. Sure it makes the examples run, and it might be good from an educational point of view, but after all, there is a good reason why eclipse has evolved into 3.4 today. So you should use the latest version :-)

What was my solution? Be aware it is by no means a perfect one, a lot of googling for answers was and is still required.
First, use the eclipse book from 2005 as a reference, it explains the basics of Eclispe RCP and the underlying OSGi framework, and might improve your understanding of the framework.
Second use online tutorials and the eclispe help functions to get started. There is a lot of documentation out there, it is just not very well structured. Be advised, as a newbie it is really hard to develop something in eclipse 3.4 that was made for earlier versions of eclipse. Many of the small things are different and this makes it really hard to find out why your code does not run.

Personally I found Lars Vogel's Eclispe RCP 3.4 tutorial to be one of the best Eclipse RCP 3.4 tutorial because it is one of the more extensive handling eclipse 3.4, Most other tutorials are from older versions.


The Eclipse Wiki can also be used, but I find it hard to search and a lot of googling is necessary to get the right answers!

Hope this was useful!

-Lars
Hong Anderson
Ranch Hand

Joined: Jul 05, 2005
Posts: 1936
Try to uncheck plug-ins and I click select required plug-ins, it might work.
I hope you get what I mean, people who use Eclipse RCP should know.


SCJA 1.0, SCJP 1.4, SCWCD 1.4, SCBCD 1.3, SCJP 5.0, SCEA 5, SCBCD 5; OCUP - Fundamental, Intermediate and Advanced; IBM Certified Solution Designer - OOAD, vUML 2; SpringSource Certified Spring Professional
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problems w/ Eclipse RCP
 
Similar Threads
Trouble when Opening Eclipse
MyEcllipse Enterprise workbech 5.1.0 GA installation problems
Problems starting Eclipse in Fedora 7. Missing sym class??
WAS toolkit eclipse startup errors after update to fixpack 17
Eclipse start Up error