aspose file tools*
The moose likes Struts and the fly likes Configration for struts2 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Configration for struts2" Watch "Configration for struts2" New topic
Author

Configration for struts2

Swaroop Reddy
Ranch Hand

Joined: Feb 25, 2009
Posts: 34
Hi all,
I want to develop an web application in Struts2,right now i am using j2sdk1.4.04 and jre1.4.04 .I want to know whether under which version of java struts 2 run comfortabily,if it doesnt run under my current configuration whats the problem


Mr.Reddy
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Struts 2 expects Java 1.5+ (see the requirements portions of the nutshell docs). Earlier versions of S2 shipped with a set of libraries suitable for use with Java 1.4; these are no longer provided in the distro but the commands for creating them are still there (I think). You could, of course, do it by hand.
Veeraraghavan Pasupathi
Greenhorn

Joined: Mar 11, 2009
Posts: 9
Struts is a MVC framework use to develop web application.
It does not have limitation with the jre, so dont worry abt this and get start with your work....


Veeraraghavan P
IT Professional
Joe Ess
Bartender

Joined: Oct 29, 2001
Posts: 8867
    
    8

Veeraraghavan Pasupathi wrote:
It does not have limitation with the jre, so dont worry abt this and get start with your work....


From the Struts 2 Home Page:


Platform Requirements
Apache Struts 2 requires:

* Servlet API 2.4
* JSP API 2.0
* Java 5
An alternate set of JARs for Java 4 are also available. See the "J4" distribution.


"blabbing like a narcissistic fool with a superiority complex" ~ N.A.
[How To Ask Questions On JavaRanch]
Veeraraghavan Pasupathi
Greenhorn

Joined: Mar 11, 2009
Posts: 9
Thanks Thanks for correcting me...
Sorry to give a wrong information....
Joe Ess
Bartender

Joined: Oct 29, 2001
Posts: 8867
    
    8

Don't let this one stop you from answering posts. We're all here to learn.
The only reason I know Struts 2 works with Java 5 and above is I just tried to deploy a Struts 2 app on Weblogic 8.1, which is Java 1.4. It came as a surprise to me, too!
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Besides, making mistakes is how we learn--otherwise we're probably not challenging ourselves.

Hmm, if the number of mistakes we make is a measure of how much we know I must be pretty smart by now :/

(WL8 was my first experience w/ S2 some time ago too; http://struts.apache.org/2.1.6/docs/weblogic-81.html -- but that page was made for S2.0.mumble/4-6ish?)
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Configration for struts2