This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Struts and the fly likes Struts2.1 div problem in tabbedpanel Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Struts2.1 div problem in tabbedpanel" Watch "Struts2.1 div problem in tabbedpanel" New topic
Author

Struts2.1 div problem in tabbedpanel

kirti dela
Greenhorn

Joined: Mar 18, 2009
Posts: 1
Hello All
I've my project setup on struts2.1,hibernate3,jpa,spring2.5.5

I've a tabbed panel which have tabs in it.
I'm loading each tab by <s:url />

My first problem is how to load these tabs onClick event of the specific tab.

second. I've a second tab which have form, list of filled information by that table so that when user click at edit data comes in the same form and he can edit it and then update. and he can delete it too but I'm getting error of
DEBUG: Error running scripts from content: undefined
Firebug. and when I click at refresh at it muliple time same action url got executed.
third is

Please suggest me how to resolve it.

MY Tabbedpannel JSP is like this.:



And my second tab JSP is Like this:


My mapping are as like this.


And my action is like this



This whole code is working fine when I was working with Struts2.0.6 and html jsp
now I'm shifting myself to struts2.1.4 and xhtml jsp so it is not working
please suggest me how to solve this issue.
I'm unable to find what is going wrong.
waiting for your kind reply
thankyou
regads
Kirti
 
 
subject: Struts2.1 div problem in tabbedpanel
 
Similar Threads
Struts2 - execAndWait Interceptor
Struts 2 | How to populate a form by selecting a value from a table in the same page
struts 2 don�t get radio button
problem in printing the values
Ajax not working on IE. Undefined error