aspose file tools*
The moose likes Websphere and the fly likes strange issue with a session/entity bean(s) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "strange issue with a session/entity bean(s)" Watch "strange issue with a session/entity bean(s)" New topic
Author

strange issue with a session/entity bean(s)

U Kvistborg
Greenhorn

Joined: Oct 14, 2002
Posts: 29
Hi

I have the strangets issue I have ever come by, I have an application that builds and deployes fine in RSA 7.0 under websphere 6.1.0.2 build cf20633.22
I have now moved my application via an ear file export and earfile import to RAD 7.5 with websphere 6.1.0.19 build cf90836.04
and it allmost works.
In both cases I am using db2 as my database and they are both 8.2, and the database is a backup from the other installation.

But when I deployes my application, or starts it it fails because one and only one of the session beans is never found.
This particular bean references 2 entity beans.

There is no difference in my application from one environment to the other, and I even have deployed the application I am importing into my new environment in our production environment.

I then desided to try to remove the entity references, and now my code finds the session bean, and it does not matter which one of these references I tries to remove. But ofcourse I get another error later on, if this reference is not there, I never get the entity beans home interface.

Other of my session beans happily references several entity beans, even if I set one of my other to reference these two particular entity beans.

And I can with out problems references my other entities from this particular session bean.

I tried to reimplement one of the entity beans and that too failed.

So I find it really really strange this particular error, that I get on this websphere server running in this version of RAD.

Anyone got any ideas ?

any one needing more info just say so.

I can add that I have now tried to install the actual ear file, that works fine in my old environment and is installed on production, into the WAS6.1 that I have with RAD, and it gives the same error, so it must be something with the actual WebSphere server that does not work.

It seems that it where the feature pack for WAS 6.1 that caused the issue, after I removed this my app works fine and as expected.


SCJP 1.4/1.5, SCWCD 1.4, SCBCD 1.3
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: strange issue with a session/entity bean(s)