Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Agile forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WAS class not fonud in classloader

 
Amit kull
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am trying to deploy a spring application on WAS Community edition.

I am getting following error:

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'jmsFactory' defined in ServletContext resource [/WEB-INF/servcesContext.xml]: Instantiation of bean failed; nested exception is java.lang.NoClassDefFoundError: org/apache/commons/pool/ObjectPoolFactory

...
caused by...
Caused by: java.lang.ClassNotFoundException: org.apache.commons.pool.ObjectPoolFactory in classloader org.apache.geronimo.configs/activemq-broker/2.1.1/car



I have the jar commons-pool-1.4.jar which contains this class in my application's classpath.
Is it necessary to have the jar in WAS CE's repository. If yes where do I need to make necessary entries of the jar like say config xmls, dependencies?

Any pointers would be helpful. Thanks.
 
Amit kull
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I fixed this problem as per the help people provided here
 
Don't get me started about those stupid light bulbs.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic